summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoroli2017-10-08 22:05:38 +0000
committeroli2017-10-08 22:05:57 +0000
commite644a73b4aa8c492057be3a543996a6f361ee71c (patch)
tree5b123ef4ae16d4eabb57b5665d970c908044d649
downloadaur-e644a73b4aa8c492057be3a543996a6f361ee71c.tar.gz
Initial version
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD45
2 files changed, 63 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0c60a710c5e9
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = nginx-mainline-mod-auth-ldap-git
+ pkgdesc = LDAP Authentication module for nginx
+ pkgver = r137.42d195d
+ pkgrel = 1
+ url = https://github.com/kvspb/nginx-auth-ldap
+ arch = i686
+ arch = x86_64
+ license = BSD
+ makedepends = git
+ depends = nginx-mainline
+ depends = libldap
+ source = https://nginx.org/download/nginx-1.13.4.tar.gz
+ source = git+https://github.com/kvspb/nginx-auth-ldap.git
+ sha256sums = de21f3c49ba65c611329d8759a63d72e5fcf719bc6f2a3270e2541348ef1fbba
+ sha256sums = SKIP
+
+pkgname = nginx-mainline-mod-auth-ldap-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..340703b9bd38
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,45 @@
+# Maintainer: Oliver Paschke <oli.paschke@gmail.com>
+
+pkgname=nginx-mainline-mod-auth-ldap-git
+pkgver=r137.42d195d
+pkgrel=1
+
+_modname=nginx-auth-ldap
+_nginxver=1.13.4
+
+pkgdesc='LDAP Authentication module for nginx'
+arch=('i686' 'x86_64')
+depends=('nginx-mainline' 'libldap')
+makedepends=('git')
+url="https://github.com/kvspb/nginx-auth-ldap"
+license=('BSD')
+
+source=(
+ https://nginx.org/download/nginx-$_nginxver.tar.gz
+ git+https://github.com/kvspb/nginx-auth-ldap.git
+)
+
+sha256sums=('de21f3c49ba65c611329d8759a63d72e5fcf719bc6f2a3270e2541348ef1fbba'
+ 'SKIP')
+
+pkgver() {
+ cd "$srcdir"/$_modname
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+
+build() {
+ cd "$srcdir"/nginx-$_nginxver
+ ./configure --with-compat --add-dynamic-module=../$_modname
+ make modules
+}
+
+package() {
+ install -Dm644 "$srcdir"/$_modname/LICENSE \
+ "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
+
+ cd "$srcdir"/nginx-$_nginxver/objs
+ for mod in *.so; do
+ install -Dm755 $mod "$pkgdir"/usr/lib/nginx/modules/$mod
+ done
+}