summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMassimiliano Torromeo2017-03-10 14:54:49 +0100
committerMassimiliano Torromeo2017-03-10 14:54:49 +0100
commita710c89728cfd02c18fd3cf9f4287b15aff9533b (patch)
treebc6074bce05966e4aafdb3a7d53d16fe91581dc1
downloadaur-a710c89728cfd02c18fd3cf9f4287b15aff9533b.tar.gz
Initial commit
-rw-r--r--.SRCINFO20
-rw-r--r--.gitignore17
-rw-r--r--PKGBUILD45
3 files changed, 82 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d4d52ad8b740
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+# Generated by mksrcinfo v8
+# Fri Mar 10 13:54:41 UTC 2017
+pkgbase = nginx-mainline-addon-auth_pam
+ pkgdesc = Nginx mainline module to use PAM for simple http authentication
+ pkgver = 1.5.1
+ pkgrel = 1
+ url = https://github.com/sto/ngx_http_auth_pam_module
+ arch = i686
+ arch = x86_64
+ license = BSD
+ depends = nginx-mainline
+ source = http://nginx.org/download/nginx-1.11.10.tar.gz
+ source = https://github.com/sto/ngx_http_auth_pam_module/archive/v1.5.1/ngx_http_auth_pam_module-1.5.1.tar.gz
+ source = ngx_http_auth_pam_module-critlog.patch::https://patch-diff.githubusercontent.com/raw/sto/ngx_http_auth_pam_module/pull/11.patch
+ sha256sums = 778b3cabb07633f754cd9dee32fc8e22582bce22bfa407be76a806abd935533d
+ sha256sums = 77676842919134af88a7b4bfca4470223e3a00d287d17c0dbdc9a114a685b6e7
+ sha256sums = 1a59787672cf9c6768cb77c31f19a870eaf556c7b28c8c22a22cf8a7013b93af
+
+pkgname = nginx-mainline-addon-auth_pam
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..9b97681014e9
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,17 @@
+*.zip
+*.jar
+*.tar
+*.tgz
+*.tbz2
+*.gz
+*.bz2
+*.xz
+*.gem
+*.run
+*.deb
+*.rpm
+*.sig
+*.log
+/src
+/pkg
+*.kate-swp
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7db74bd3416e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,45 @@
+# Maintainer: Massimiliano Torromeo <massimiliano.torromeo@gmail.com>
+
+pkgname=nginx-mainline-addon-auth_pam
+pkgver=1.5.1
+pkgrel=1
+
+_modname=ngx_http_auth_pam_module
+_nginxver=1.11.10
+
+pkgdesc='Nginx mainline module to use PAM for simple http authentication'
+arch=('i686' 'x86_64')
+depends=('nginx-mainline')
+url="https://github.com/sto/ngx_http_auth_pam_module"
+license=('BSD')
+
+source=(
+ http://nginx.org/download/nginx-$_nginxver.tar.gz
+ https://github.com/sto/$_modname/archive/v$pkgver/$_modname-$pkgver.tar.gz
+ $_modname-critlog.patch::https://patch-diff.githubusercontent.com/raw/sto/ngx_http_auth_pam_module/pull/11.patch
+)
+
+sha256sums=('778b3cabb07633f754cd9dee32fc8e22582bce22bfa407be76a806abd935533d'
+ '77676842919134af88a7b4bfca4470223e3a00d287d17c0dbdc9a114a685b6e7'
+ '1a59787672cf9c6768cb77c31f19a870eaf556c7b28c8c22a22cf8a7013b93af')
+
+prepare() {
+ cd "$srcdir"/$_modname-$pkgver
+ patch -p1 -i "$srcdir"/$_modname-critlog.patch
+}
+
+build() {
+ cd "$srcdir"/nginx-$_nginxver
+ ./configure $(nginx -V 2>&1 | grep 'configure arguments' | sed -r 's@^[^:]+: @@') --add-dynamic-module=../$_modname-$pkgver
+ make modules
+}
+
+package() {
+ install -Dm644 "$srcdir"/$_modname-$pkgver/LICENSE \
+ "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
+
+ cd "$srcdir"/nginx-$_nginxver/objs
+ for mod in *.so; do
+ install -Dm755 $mod "$pkgdir"/usr/lib/nginx/modules/$mod
+ done
+}