summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGregor Reitzenstein2017-08-29 17:49:18 +0200
committerGregor Reitzenstein2017-08-29 17:49:18 +0200
commitece4ae452f5b1acb1cff45f92203ee1efd2ccc56 (patch)
treeb4c135ecfc863acdac6aba8581c058967c04e924
downloadaur-ece4ae452f5b1acb1cff45f92203ee1efd2ccc56.tar.gz
Initial commit
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD39
2 files changed, 56 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..77d6f07cc50b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = nginx-mainline-mod-auth_spnego
+ pkgdesc = Nginx module to use SPNEGO for http authentication
+ pkgver = 1.1.0
+ pkgrel = 1
+ url = https://github.com/stnoonan/spnego-http-auth-nginx-module
+ arch = i686
+ arch = x86_64
+ license = BSD
+ depends = nginx-mainline
+ depends = krb5
+ source = https://nginx.org/download/nginx-1.13.3.tar.gz
+ source = git+https://github.com/stnoonan/spnego-http-auth-nginx-module.git
+ sha256sums = 5b73f98004c302fb8e4a172abf046d9ce77739a82487e4873b39f9b0dcbb0d72
+ sha256sums = SKIP
+
+pkgname = nginx-mainline-mod-auth_spnego
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..10af81e819b9
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,39 @@
+# Maintainer: Gregor Reitzenstein <dequbed@paranoidlabs.org>
+
+pkgname=nginx-mainline-mod-auth_spnego
+pkgver=1.1.0
+pkgrel=1
+
+_modname=spnego-http-auth-nginx-module
+_nginxver=1.13.3
+
+pkgdesc='Nginx module to use SPNEGO for http authentication'
+arch=('i686' 'x86_64')
+depends=('nginx-mainline' 'krb5')
+url="https://github.com/stnoonan/spnego-http-auth-nginx-module"
+license=('BSD')
+
+source=(
+ https://nginx.org/download/nginx-$_nginxver.tar.gz
+ git+https://github.com/stnoonan/spnego-http-auth-nginx-module.git
+)
+
+sha256sums=('5b73f98004c302fb8e4a172abf046d9ce77739a82487e4873b39f9b0dcbb0d72'
+ 'SKIP')
+
+build() {
+ cd "$srcdir"/nginx-$_nginxver
+ #./configure --with-cc-opts=-Wno-error --with-compat --add-dynamic-module=../$_modname-$pkgver
+ ./configure --with-compat --add-dynamic-module=../$_modname
+ make modules
+}
+
+package() {
+ install -Dm644 "$srcdir"/$_modname/LICENSE \
+ "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
+
+ cd "$srcdir"/nginx-$_nginxver/objs
+ for mod in *.so; do
+ install -Dm755 $mod "$pkgdir"/usr/lib/nginx/modules/$mod
+ done
+}