summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMassimiliano Torromeo2017-04-13 11:55:08 +0200
committerMassimiliano Torromeo2017-04-13 11:55:08 +0200
commit73440fd8d2cd8032c37563b7262e07d8a191b515 (patch)
treefa3ac71ced284107e14a4b0bc980e46dfa15f3a2
parentbd3ef006560fb3415a4e54d41e48a0a28c20b74a (diff)
downloadaur-73440fd8d2cd8032c37563b7262e07d8a191b515.tar.gz
Updated for nginx 1.12.0
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD15
2 files changed, 17 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 70d4b472c6e0..4dffe8a167ab 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,20 @@
# Generated by mksrcinfo v8
-# Thu Apr 6 09:27:35 UTC 2017
+# Thu Apr 13 09:55:08 UTC 2017
pkgbase = nginx-mainline-mod-echo
pkgdesc = Directives "echo", "sleep", "time" and more (module for mainline nginx)
pkgver = 0.60
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/openresty/echo-nginx-module
arch = i686
arch = x86_64
license = BSD
depends = nginx-mainline
- source = http://nginx.org/download/nginx-1.11.10.tar.gz
+ source = http://nginx.org/download/nginx-1.12.0.tar.gz
source = https://github.com/openresty/echo-nginx-module/archive/v0.60/echo-0.60.tar.gz
- sha256sums = 778b3cabb07633f754cd9dee32fc8e22582bce22bfa407be76a806abd935533d
+ source = nginx-mainline-mod-echo-nginx-1.12.patch::https://patch-diff.githubusercontent.com/raw/openresty/echo-nginx-module/pull/65.patch
+ sha256sums = b4222e26fdb620a8d3c3a3a8b955e08b713672e1bc5198d1e4f462308a795b30
sha256sums = 1077da2229ac7d0a0215e9e6817e297c10697e095010d88f1adbd1add1ce9f4e
+ sha256sums = cab48c257748e5576a5a6c86965f8ff36d6a36b845d1e9c81f3d2cc0151737c4
pkgname = nginx-mainline-mod-echo
diff --git a/PKGBUILD b/PKGBUILD
index 5728729e61c1..7d4309bb2ff9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,10 +2,10 @@
pkgname=nginx-mainline-mod-echo
pkgver=0.60
-pkgrel=1
+pkgrel=2
_modname="${pkgname#nginx-mainline-mod-}"
-_nginxver=1.11.10
+_nginxver=1.12.0
pkgdesc='Directives "echo", "sleep", "time" and more (module for mainline nginx)'
arch=('i686' 'x86_64')
@@ -16,10 +16,17 @@ license=('BSD')
source=(
http://nginx.org/download/nginx-$_nginxver.tar.gz
https://github.com/openresty/$_modname-nginx-module/archive/v$pkgver/$_modname-$pkgver.tar.gz
+ $pkgname-nginx-1.12.patch::https://patch-diff.githubusercontent.com/raw/openresty/echo-nginx-module/pull/65.patch
)
-sha256sums=('778b3cabb07633f754cd9dee32fc8e22582bce22bfa407be76a806abd935533d'
- '1077da2229ac7d0a0215e9e6817e297c10697e095010d88f1adbd1add1ce9f4e')
+sha256sums=('b4222e26fdb620a8d3c3a3a8b955e08b713672e1bc5198d1e4f462308a795b30'
+ '1077da2229ac7d0a0215e9e6817e297c10697e095010d88f1adbd1add1ce9f4e'
+ 'cab48c257748e5576a5a6c86965f8ff36d6a36b845d1e9c81f3d2cc0151737c4')
+
+prepare() {
+ cd $_modname-nginx-module-$pkgver
+ patch -p1 -i "$srcdir"/$pkgname-nginx-1.12.patch
+}
build() {
cd "$srcdir"/nginx-$_nginxver