summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorHoàng Đức Hiếu2017-07-20 09:48:18 +0700
committerHoàng Đức Hiếu2017-07-20 09:48:18 +0700
commit6e7894fbdcbf7e696c9c12195380785fa296575a (patch)
treee679d8d81e3166171b01afad64674f7209650b46
parentdb86848d925207939bc0e80f1f8f28c80e096b41 (diff)
downloadaur-6e7894fbdcbf7e696c9c12195380785fa296575a.tar.gz
fix cc-options for nginx 1.13.3-2
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD10
2 files changed, 9 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 86e2cf0681e1..196500d44ce9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = nginx-mainline-mod-fancyindex
pkgdesc = Fancy indexes module for the Nginx web server
pkgver = 0.4.1
- pkgrel = 5
+ pkgrel = 6
url = https://github.com/aperezdc/ngx-fancyindex
arch = i686
arch = x86_64
diff --git a/PKGBUILD b/PKGBUILD
index dba7032639a1..785a990397a7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=nginx-mainline-mod-fancyindex
pkgver=0.4.1
-pkgrel=5
+pkgrel=6
_modname="${pkgname#nginx-mainline-mod-}"
_nginxver="$(/bin/nginx -v 2>&1 | grep -Eo '([[:digit:]]|\.)+')"
@@ -24,7 +24,13 @@ prepare() {
build() {
cd "$srcdir"/nginx-$_nginxver
- ./configure $(nginx -V 2>&1 | grep 'configure arguments' | sed -r 's@^[^:]+: @@') --add-dynamic-module=../ngx-$_modname-$pkgver
+ old_IFS=${IFS}
+ IFS=\'
+ configure_arguments=($(nginx -V |& grep configure | cut -d ' ' -f 3-))
+ IFS=${old_IFS}
+ ./configure ${configure_arguments[0]}"${configure_arguments[1]}" \
+ ${configure_arguments[2]} \
+ --add-dynamic-module=../ngx-$_modname-$pkgver
make modules
}