summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorHoàng Đức Hiếu2017-07-20 10:11:11 +0700
committerHoàng Đức Hiếu2017-07-20 10:11:11 +0700
commit73bfb58a6a849c23801623a0b6b5fab7c2ad253d (patch)
tree3b2a7a543efd95b38ceb0f1c97500d8382243475
parent6e7894fbdcbf7e696c9c12195380785fa296575a (diff)
downloadaur-73bfb58a6a849c23801623a0b6b5fab7c2ad253d.tar.gz
properly fix opts
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD11
2 files changed, 5 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 196500d44ce9..2c03a2e879cd 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = nginx-mainline-mod-fancyindex
pkgdesc = Fancy indexes module for the Nginx web server
pkgver = 0.4.1
- pkgrel = 6
+ pkgrel = 7
url = https://github.com/aperezdc/ngx-fancyindex
arch = i686
arch = x86_64
diff --git a/PKGBUILD b/PKGBUILD
index 785a990397a7..4f1d243be05d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=nginx-mainline-mod-fancyindex
pkgver=0.4.1
-pkgrel=6
+pkgrel=7
_modname="${pkgname#nginx-mainline-mod-}"
_nginxver="$(/bin/nginx -v 2>&1 | grep -Eo '([[:digit:]]|\.)+')"
@@ -24,12 +24,9 @@ prepare() {
build() {
cd "$srcdir"/nginx-$_nginxver
- old_IFS=${IFS}
- IFS=\'
- configure_arguments=($(nginx -V |& grep configure | cut -d ' ' -f 3-))
- IFS=${old_IFS}
- ./configure ${configure_arguments[0]}"${configure_arguments[1]}" \
- ${configure_arguments[2]} \
+ opts=$(nginx -V 2>&1 | grep 'configure arguments' | sed -r 's@^[^:]+: @@')
+ IFS=$'\n' opts=( $(xargs -n1 <<< "$opts") )
+ ./configure "${opts[@]}" \
--add-dynamic-module=../ngx-$_modname-$pkgver
make modules
}