summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMassimiliano Torromeo2017-04-06 12:39:56 +0200
committerMassimiliano Torromeo2017-04-06 12:39:56 +0200
commit7795974b80ef8c84e0431e8c4b6442dfdf0350d8 (patch)
tree29db91ff837cd23c98d92a63c4933b41207c47d0
downloadaur-7795974b80ef8c84e0431e8c4b6442dfdf0350d8.tar.gz
Initial commit
-rw-r--r--.SRCINFO19
-rw-r--r--.gitignore17
-rw-r--r--PKGBUILD38
3 files changed, 74 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b8702983dffd
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+# Generated by mksrcinfo v8
+# Thu Apr 6 10:39:50 UTC 2017
+pkgbase = nginx-mainline-mod-geoip2
+ pkgdesc = GeoIP2 module for mainline nginx
+ pkgver = 2.0
+ pkgrel = 1
+ url = https://github.com/leev/ngx_http_geoip2_module
+ arch = i686
+ arch = x86_64
+ license = BSD
+ depends = nginx-mainline
+ depends = libmaxminddb
+ source = http://nginx.org/download/nginx-1.11.10.tar.gz
+ source = https://github.com/leev/ngx_http_geoip2_module/archive/2.0/ngx_http_geoip2_module-2.0.tar.gz
+ sha256sums = 778b3cabb07633f754cd9dee32fc8e22582bce22bfa407be76a806abd935533d
+ sha256sums = ebb4652c4f9a2e1ee31fddefc4c93ff78e651a4b2727d3453d026bccbd708d99
+
+pkgname = nginx-mainline-mod-geoip2
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..9b97681014e9
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,17 @@
+*.zip
+*.jar
+*.tar
+*.tgz
+*.tbz2
+*.gz
+*.bz2
+*.xz
+*.gem
+*.run
+*.deb
+*.rpm
+*.sig
+*.log
+/src
+/pkg
+*.kate-swp
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0249ffb2e0db
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+# Maintainer: Massimiliano Torromeo <massimiliano.torromeo@gmail.com>
+
+pkgname=nginx-mainline-mod-geoip2
+pkgver=2.0
+pkgrel=1
+
+_modname="ngx_http_geoip2_module"
+_nginxver=1.11.10
+
+pkgdesc="GeoIP2 module for mainline nginx"
+arch=('i686' 'x86_64')
+depends=('nginx-mainline' 'libmaxminddb')
+url="https://github.com/leev/ngx_http_geoip2_module"
+license=('BSD')
+
+source=(
+ http://nginx.org/download/nginx-$_nginxver.tar.gz
+ https://github.com/leev/ngx_http_geoip2_module/archive/$pkgver/$_modname-$pkgver.tar.gz
+)
+
+sha256sums=('778b3cabb07633f754cd9dee32fc8e22582bce22bfa407be76a806abd935533d'
+ 'ebb4652c4f9a2e1ee31fddefc4c93ff78e651a4b2727d3453d026bccbd708d99')
+
+build() {
+ cd "$srcdir"/nginx-$_nginxver
+ ./configure $(nginx -V 2>&1 | grep 'configure arguments' | sed -r 's@^[^:]+: @@') --add-dynamic-module=../$_modname-$pkgver
+ make modules
+}
+
+package() {
+ install -Dm644 "$srcdir"/$_modname-$pkgver/LICENSE \
+ "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
+
+ cd "$srcdir"/nginx-$_nginxver/objs
+ for mod in ngx_*.so; do
+ install -Dm755 $mod "$pkgdir"/usr/lib/nginx/modules/$mod
+ done
+}