summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMassimiliano Torromeo2017-04-06 11:39:49 +0200
committerMassimiliano Torromeo2017-04-06 11:39:49 +0200
commitc433a7937a7e1452ddf8c428ec8532797e05b112 (patch)
tree9bad4a5a67c5d4dc710bc7d56678a78f8a1e960e
downloadaur-c433a7937a7e1452ddf8c428ec8532797e05b112.tar.gz
Renamed package
-rw-r--r--.SRCINFO18
-rw-r--r--.gitignore17
-rw-r--r--PKGBUILD35
3 files changed, 70 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..05a67736322a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+# Generated by mksrcinfo v8
+# Thu Apr 6 09:27:35 UTC 2017
+pkgbase = nginx-mainline-mod-headers-more
+ pkgdesc = Set and clear input and output headers (module for mainline nginx)
+ pkgver = 0.32
+ pkgrel = 1
+ url = https://github.com/openresty/headers-more-nginx-module
+ arch = i686
+ arch = x86_64
+ license = BSD
+ depends = nginx-mainline
+ source = http://nginx.org/download/nginx-1.11.10.tar.gz
+ source = https://github.com/openresty/headers-more-nginx-module/archive/v0.32/headers-more-0.32.tar.gz
+ sha256sums = 778b3cabb07633f754cd9dee32fc8e22582bce22bfa407be76a806abd935533d
+ sha256sums = c6d9dab8ea1fc997031007e2e8f47cced01417e203cd88d53a9fe9f6ae138720
+
+pkgname = nginx-mainline-mod-headers-more
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..9b97681014e9
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,17 @@
+*.zip
+*.jar
+*.tar
+*.tgz
+*.tbz2
+*.gz
+*.bz2
+*.xz
+*.gem
+*.run
+*.deb
+*.rpm
+*.sig
+*.log
+/src
+/pkg
+*.kate-swp
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..022fa1659898
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: Massimiliano Torromeo <massimiliano.torromeo@gmail.com>
+
+pkgname=nginx-mainline-mod-headers-more
+pkgver=0.32
+pkgrel=1
+
+_modname="${pkgname#nginx-mainline-mod-}"
+_nginxver=1.11.10
+
+pkgdesc="Set and clear input and output headers (module for mainline nginx)"
+arch=('i686' 'x86_64')
+depends=('nginx-mainline')
+url="https://github.com/openresty/headers-more-nginx-module"
+license=('BSD')
+
+source=(
+ http://nginx.org/download/nginx-$_nginxver.tar.gz
+ https://github.com/openresty/$_modname-nginx-module/archive/v$pkgver/$_modname-$pkgver.tar.gz
+)
+
+sha256sums=('778b3cabb07633f754cd9dee32fc8e22582bce22bfa407be76a806abd935533d'
+ 'c6d9dab8ea1fc997031007e2e8f47cced01417e203cd88d53a9fe9f6ae138720')
+
+build() {
+ cd "$srcdir"/nginx-$_nginxver
+ ./configure $(nginx -V 2>&1 | grep 'configure arguments' | sed -r 's@^[^:]+: @@') --add-dynamic-module=../$_modname-nginx-module-$pkgver
+ make modules
+}
+
+package() {
+ cd "$srcdir"/nginx-$_nginxver/objs
+ for mod in *.so; do
+ install -Dm755 $mod "$pkgdir"/usr/lib/nginx/modules/$mod
+ done
+}