summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJakub Schmidtke2021-02-02 17:44:54 +0100
committerJakub Schmidtke2021-02-02 17:44:54 +0100
commit67cd213444942f9008c7247d12db7863e5310c66 (patch)
tree7670f912e559cc77c6c60b28b5a1a2d21540fd3d
parent50252cdf6be99c9ab0a7258958589fd89474a136 (diff)
downloadaur-67cd213444942f9008c7247d12db7863e5310c66.tar.gz
Updated PKGBUILD based on nginx-mod-http-xslt-filter package; Bumped nginx version
-rw-r--r--.SRCINFO17
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD55
3 files changed, 32 insertions, 41 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4970d28dd4d2..33e905699b19 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,20 +1,13 @@
pkgbase = nginx-mainline-mod-http-xslt-filter
pkgdesc = HTTP XSLT module for the Nginx mainline web server
- pkgver = 1.17.10
- pkgrel = 1
- url = https://nginx.org
- arch = i686
+ pkgver = 1.19.6
+ pkgrel = 2
+ url = https://nginx.org/en/docs/http/ngx_http_xslt_module.html
arch = x86_64
- arch = armv7h
- arch = aarch64
- license = custom
+ license = custom:BSD-2-Clause
+ makedepends = nginx-mainline-src
depends = nginx-mainline
depends = libxslt
- source = https://nginx.org/download/nginx-1.17.10.tar.gz
- source = https://nginx.org/download/nginx-1.17.10.tar.gz.asc
- validpgpkeys = B0F4253373F8F6F510D42178520A9993A1C052F8
- sha256sums = a9aa73f19c352a6b166d78e2a664bb3ef1295bbe6d3cc5aa7404bd4664ab4b83
- sha256sums = SKIP
pkgname = nginx-mainline-mod-http-xslt-filter
diff --git a/.gitignore b/.gitignore
index 9b5ba7ef40f4..21c2f1539bd7 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,3 +1,4 @@
+*~
*.tar.gz
*.pkg.tar*
src/
diff --git a/PKGBUILD b/PKGBUILD
index 29380d0b3132..6f7160b547df 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,40 +1,37 @@
-# Maintainer:
+# Maintainer: Jakub Schmidtke <sjakub-at-gmail-dot-com>
# Contributor: Felix Golatofski <contact@xdfr.de>
# Contributor: Sergey Shatunov <me@prok.pw>
-pkgname=nginx-mainline-mod-http-xslt-filter
-pkgver=1.17.10
-pkgrel=1
-
-_modname="${pkgname#nginx-mainline-mod-}"
-
-pkgdesc='HTTP XSLT module for the Nginx mainline web server'
-arch=('i686' 'x86_64' 'armv7h' 'aarch64')
+# Based on nginx-mod-http-xslt-filter AUR package.
+
+pkgname='nginx-mainline-mod-http-xslt-filter'
+#pkgver=$(pacman -Si nginx-mainline-src | sed -nE 's/^Version *: ([[:alnum:]._]+).*$/\1/p')
+pkgver=1.19.6
+#pkgrel=$(pacman -Si nginx-mainline-src | sed -nE 's/^Version *: [^-]+-(.*)$/\1/p')
+pkgrel=2
+pkgdesc="HTTP XSLT module for the Nginx mainline web server"
+arch=('x86_64')
+url='https://nginx.org/en/docs/http/ngx_http_xslt_module.html'
+license=('custom:BSD-2-Clause')
depends=('nginx-mainline' 'libxslt')
-url="https://nginx.org"
-license=('custom')
-
-source=(https://nginx.org/download/nginx-$pkgver.tar.gz{,.asc}
-)
+makedepends=('nginx-mainline-src')
-validpgpkeys=(
- 'B0F4253373F8F6F510D42178520A9993A1C052F8' # Maxim Dounin <mdounin@mdounin.ru>
-)
-
-sha256sums=('a9aa73f19c352a6b166d78e2a664bb3ef1295bbe6d3cc5aa7404bd4664ab4b83'
- 'SKIP')
+prepare() {
+ cp -r /usr/src/nginx/ ./
+}
build() {
- cd "$srcdir"/nginx-$pkgver
- opts=$(nginx -V 2>&1 | grep 'configure arguments' | sed -r 's@^[^:]+: @@')
- IFS=$'\n' opts=( $(xargs -n1 <<< "$opts") )
- ./configure "${opts[@]}" --with-http_xslt_module=dynamic
- make modules
+ cd nginx
+ _options=$(nginx -V |&
+ sed -nE 's/^configure arguments: ([^\n]*)$/\1/p' |
+ sed -nE 's/([^'"'"' \t\n]+('"'"'([^'"'"'\]|\\'"'"'?)*'"'"'|"([^"\\]|\\"?)*")?) ?/\1\n/gp')
+ IFS=$'\n' xargs ./configure --with-http_xslt_module=dynamic <<< ${_options[@]}
+ make modules
}
package() {
- cd "$srcdir"/nginx-$pkgver/objs
- for mod in *.so; do
- install -Dm755 $mod "$pkgdir"/usr/lib/nginx/modules/$mod
- done
+ cd "nginx/objs"
+ for f in *.so; do install -Dm644 "$f" "$pkgdir/usr/lib/nginx/modules/$f"; done
+ install -dm755 "$pkgdir/usr/share/licenses/"
+ ln -s /usr/share/licenses/nginx/ "$pkgdir/usr/share/licenses/$pkgname"
}