summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMassimiliano Torromeo2017-04-06 11:39:49 +0200
committerMassimiliano Torromeo2017-04-06 11:39:49 +0200
commitbedd8ad0eb8773831b48496df8446e98f5f0459f (patch)
tree1861d02b53fa596d43018762edeb1810115e08a2
downloadaur-bedd8ad0eb8773831b48496df8446e98f5f0459f.tar.gz
Renamed package
-rw-r--r--.SRCINFO20
-rw-r--r--.gitignore17
-rw-r--r--PKGBUILD35
3 files changed, 72 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..230f99f152bb
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+# Generated by mksrcinfo v8
+# Thu Apr 6 09:27:35 UTC 2017
+pkgbase = nginx-mainline-mod-lua
+ pkgdesc = Lua script engine module for mainline nginx
+ pkgver = 0.10.7
+ pkgrel = 1
+ url = https://github.com/openresty/lua-nginx-module
+ arch = i686
+ arch = x86_64
+ license = BSD
+ depends = nginx-mainline
+ depends = nginx-mainline-mod-ndk
+ depends = luajit
+ source = http://nginx.org/download/nginx-1.11.10.tar.gz
+ source = https://github.com/openresty/lua-nginx-module/archive/v0.10.7/lua-0.10.7.tar.gz
+ sha256sums = 778b3cabb07633f754cd9dee32fc8e22582bce22bfa407be76a806abd935533d
+ sha256sums = c21c8937dcdd6fc2b6a955f929e3f4d1388610f47180e60126e6dcab06786f77
+
+pkgname = nginx-mainline-mod-lua
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..9b97681014e9
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,17 @@
+*.zip
+*.jar
+*.tar
+*.tgz
+*.tbz2
+*.gz
+*.bz2
+*.xz
+*.gem
+*.run
+*.deb
+*.rpm
+*.sig
+*.log
+/src
+/pkg
+*.kate-swp
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..68946b3deaef
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: Massimiliano Torromeo <massimiliano.torromeo@gmail.com>
+
+pkgname=nginx-mainline-mod-lua
+pkgver=0.10.7
+pkgrel=1
+
+_modname="${pkgname#nginx-mainline-mod-}"
+_nginxver=1.11.10
+
+pkgdesc='Lua script engine module for mainline nginx'
+arch=('i686' 'x86_64')
+depends=('nginx-mainline' 'nginx-mainline-mod-ndk' 'luajit')
+url="https://github.com/openresty/lua-nginx-module"
+license=('BSD')
+
+source=(
+ http://nginx.org/download/nginx-$_nginxver.tar.gz
+ https://github.com/openresty/$_modname-nginx-module/archive/v$pkgver/$_modname-$pkgver.tar.gz
+)
+
+sha256sums=('778b3cabb07633f754cd9dee32fc8e22582bce22bfa407be76a806abd935533d'
+ 'c21c8937dcdd6fc2b6a955f929e3f4d1388610f47180e60126e6dcab06786f77')
+
+build() {
+ cd "$srcdir"/nginx-$_nginxver
+ ./configure $(nginx -V 2>&1 | grep 'configure arguments' | sed -r 's@^[^:]+: @@') --add-dynamic-module=../$_modname-nginx-module-$pkgver
+ make modules
+}
+
+package() {
+ cd "$srcdir"/nginx-$_nginxver/objs
+ for mod in *.so; do
+ install -Dm755 $mod "$pkgdir"/usr/lib/nginx/modules/$mod
+ done
+}