summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMassimiliano Torromeo2017-04-29 19:51:55 +0200
committerMassimiliano Torromeo2017-04-29 19:51:55 +0200
commitf33bcca93cfc4e0b888ffefb598429b73436e95d (patch)
tree241ae4054fa39bec2829867f22deeea4657f7d95
parentfbe3d26785e34e6d2df15378a636d649463bec8f (diff)
downloadaur-f33bcca93cfc4e0b888ffefb598429b73436e95d.tar.gz
Applied patch for nginx >= 1.11.11
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD12
2 files changed, 16 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 162c09b75093..9a7d9cbc03b2 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Thu Apr 27 12:52:26 UTC 2017
+# Sat Apr 29 17:51:37 UTC 2017
pkgbase = nginx-mainline-mod-lua
pkgdesc = Lua script engine module for mainline nginx
- pkgver = 0.10.7
- pkgrel = 3
+ pkgver = 0.10.8
+ pkgrel = 1
url = https://github.com/openresty/lua-nginx-module
arch = i686
arch = x86_64
@@ -12,9 +12,11 @@ pkgbase = nginx-mainline-mod-lua
depends = nginx-mainline-mod-ndk
depends = luajit
source = http://nginx.org/download/nginx-1.13.0.tar.gz
- source = https://github.com/openresty/lua-nginx-module/archive/v0.10.7/lua-0.10.7.tar.gz
+ source = https://github.com/openresty/lua-nginx-module/archive/v0.10.8/lua-0.10.8.tar.gz
+ source = nginx-mainline-mod-lua-nginx-1.11.11.patch::https://github.com/openresty/lua-nginx-module/commit/0459a285ca0159d45e73da8bd1164edb5c57cde3.patch
sha256sums = 79f52ab6550f854e14439369808105b5780079769d7b8db3856be03c683605d7
- sha256sums = c21c8937dcdd6fc2b6a955f929e3f4d1388610f47180e60126e6dcab06786f77
+ sha256sums = d67449c71051b3cc2d6dd60df0ae0d21fca08aa19c9b30c5b95ee21ff38ef8dd
+ sha256sums = 57867eda9eeee7fe5b55d8916047c8e5ffd156cfed4ca2d64470ae4132784261
pkgname = nginx-mainline-mod-lua
diff --git a/PKGBUILD b/PKGBUILD
index 7517c6ea2c51..e844beb7af51 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
# Maintainer: Massimiliano Torromeo <massimiliano.torromeo@gmail.com>
pkgname=nginx-mainline-mod-lua
-pkgver=0.10.7
-pkgrel=3
+pkgver=0.10.8
+pkgrel=1
_modname="${pkgname#nginx-mainline-mod-}"
_nginxver=1.13.0
@@ -16,11 +16,17 @@ license=('BSD')
source=(
http://nginx.org/download/nginx-$_nginxver.tar.gz
https://github.com/openresty/$_modname-nginx-module/archive/v$pkgver/$_modname-$pkgver.tar.gz
+ $pkgname-nginx-1.11.11.patch::https://github.com/openresty/lua-nginx-module/commit/0459a285ca0159d45e73da8bd1164edb5c57cde3.patch
)
sha256sums=('79f52ab6550f854e14439369808105b5780079769d7b8db3856be03c683605d7'
- 'c21c8937dcdd6fc2b6a955f929e3f4d1388610f47180e60126e6dcab06786f77')
+ 'd67449c71051b3cc2d6dd60df0ae0d21fca08aa19c9b30c5b95ee21ff38ef8dd'
+ '57867eda9eeee7fe5b55d8916047c8e5ffd156cfed4ca2d64470ae4132784261')
+prepare() {
+ cd "$srcdir"/$_modname-nginx-module-$pkgver
+ patch -p1 -i "$srcdir"/$pkgname-nginx-1.11.11.patch
+}
build() {
cd "$srcdir"/nginx-$_nginxver
./configure $(nginx -V 2>&1 | grep 'configure arguments' | sed -r 's@^[^:]+: @@') --add-dynamic-module=../$_modname-nginx-module-$pkgver