summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMassimiliano Torromeo2017-07-24 10:23:46 +0200
committerMassimiliano Torromeo2017-07-24 10:23:46 +0200
commitb9f4a257c9048a3f8b514cf967e41ff218aa9bd5 (patch)
tree83a9976c83a32edcdbd0f431dc91ba8534b7e48f
parent496fdb94b649f9fdf834f82f4035ef16660f0411 (diff)
downloadaur-b9f4a257c9048a3f8b514cf967e41ff218aa9bd5.tar.gz
Updated to 0.18-2
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD17
2 files changed, 9 insertions, 18 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 66467a509a5c..3566b994e8df 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,20 +1,18 @@
# Generated by mksrcinfo v8
-# Mon Jun 26 07:39:57 UTC 2017
+# Mon Jul 24 08:23:39 UTC 2017
pkgbase = nginx-mainline-mod-memc
pkgdesc = Extended version of the standard memcached module for mainline nginx
pkgver = 0.18
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/openresty/memc-nginx-module
arch = i686
arch = x86_64
license = BSD
depends = nginx-mainline
- source = https://nginx.org/download/nginx-1.13.1.tar.gz
+ source = https://nginx.org/download/nginx-1.13.3.tar.gz
source = https://github.com/openresty/memc-nginx-module/archive/v0.18/memc-0.18.tar.gz
- source = nginx-mainline-mod-memc-0.18-default_port.patch::https://github.com/openresty/memc-nginx-module/commit/c08cb7043440e427867838caf21cfd1e6cb2127a.patch
- sha256sums = a5856c72a6609a4dc68c88a7f3c33b79e6693343b62952e021e043fe347b6776
+ sha256sums = 5b73f98004c302fb8e4a172abf046d9ce77739a82487e4873b39f9b0dcbb0d72
sha256sums = 4e280d1dcb8b312bc7875604c1e35b17879279126d3d5fbf482aa9cc7c11276d
- sha256sums = b5f9b83a0d2a08f1efc71ce8099eaa4e1d283afd502a7062ac4f150d569140ff
pkgname = nginx-mainline-mod-memc
diff --git a/PKGBUILD b/PKGBUILD
index 90556464609e..534564a057cc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,10 +2,10 @@
pkgname=nginx-mainline-mod-memc
pkgver=0.18
-pkgrel=1
+pkgrel=2
_modname="${pkgname#nginx-mainline-mod-}"
-_nginxver=1.13.1
+_nginxver=1.13.3
pkgdesc='Extended version of the standard memcached module for mainline nginx'
arch=('i686' 'x86_64')
@@ -16,21 +16,14 @@ license=('BSD')
source=(
https://nginx.org/download/nginx-$_nginxver.tar.gz
https://github.com/openresty/$_modname-nginx-module/archive/v$pkgver/$_modname-$pkgver.tar.gz
- $pkgname-$pkgver-default_port.patch::https://github.com/openresty/memc-nginx-module/commit/c08cb7043440e427867838caf21cfd1e6cb2127a.patch
)
-sha256sums=('a5856c72a6609a4dc68c88a7f3c33b79e6693343b62952e021e043fe347b6776'
- '4e280d1dcb8b312bc7875604c1e35b17879279126d3d5fbf482aa9cc7c11276d'
- 'b5f9b83a0d2a08f1efc71ce8099eaa4e1d283afd502a7062ac4f150d569140ff')
-
-prepare() {
- cd "$srcdir"/$_modname-nginx-module-$pkgver
- patch -p1 -i "$srcdir"/$pkgname-$pkgver-default_port.patch
-}
+sha256sums=('5b73f98004c302fb8e4a172abf046d9ce77739a82487e4873b39f9b0dcbb0d72'
+ '4e280d1dcb8b312bc7875604c1e35b17879279126d3d5fbf482aa9cc7c11276d')
build() {
cd "$srcdir"/nginx-$_nginxver
- ./configure $(nginx -V 2>&1 | grep 'configure arguments' | sed -r 's@^[^:]+: @@') --add-dynamic-module=../$_modname-nginx-module-$pkgver
+ ./configure --with-compat --add-dynamic-module=../$_modname-nginx-module-$pkgver
make modules
}