summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorДамјан Георгиевски2017-06-11 20:27:38 +0200
committerДамјан Георгиевски2017-06-11 20:27:38 +0200
commit56e84c79e4ff8f69b00ae4a75b8ce29bbee9e6dc (patch)
tree8d8803ed5e33849328b0610bc5f81300d78e5b21
downloadaur-56e84c79e4ff8f69b00ae4a75b8ce29bbee9e6dc.tar.gz
first commit
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD37
2 files changed, 53 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..71cb6c2d9eba
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = nginx-mainline-mod-nchan
+ pkgdesc = nchan nginx module
+ pkgver = 1.1.6
+ pkgrel = 1
+ url = https://nchan.io/
+ arch = i686
+ arch = x86_64
+ license = MIT
+ depends = nginx-mainline
+ source = http://nginx.org/download/nginx-1.13.1.tar.gz
+ source = https://github.com/slact/nchan/archive/v1.1.6.tar.gz
+ sha256sums = a5856c72a6609a4dc68c88a7f3c33b79e6693343b62952e021e043fe347b6776
+ sha256sums = df037766e3a152d8cf2a8b644dd10db8cac3679523adc3c063d41ffeb20d43bc
+
+pkgname = nginx-mainline-mod-nchan
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c8db276a9452
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# Maintainer: Damjan Georgievski <gdamjan@gmail.com>
+
+pkgname=nginx-mainline-mod-nchan
+pkgver=1.1.6
+pkgrel=1
+
+_nginxver=1.13.1
+
+pkgdesc='nchan nginx module'
+arch=('i686' 'x86_64')
+depends=('nginx-mainline')
+url="https://nchan.io/"
+license=('MIT')
+
+source=(
+ http://nginx.org/download/nginx-$_nginxver.tar.gz
+ https://github.com/slact/nchan/archive/v${pkgver}.tar.gz
+)
+
+
+build() {
+ cd "$srcdir"/nginx-$_nginxver
+ _module_dir="$srcdir"/nchan-$pkgver
+ _nginx_configure_options=$(nginx -V 2>&1 | grep 'configure arguments' | sed -r 's@^[^:]+: @@')
+ ./configure ${_nginx_configure_options} --add-dynamic-module=${_module_dir}
+ make modules
+}
+
+package() {
+ cd "$srcdir"/nginx-$_nginxver/objs
+ for _mod in ngx_nchan_module.so; do
+ install -Dm755 $_mod "$pkgdir"/usr/lib/nginx/modules/$_mod
+ done
+}
+
+sha256sums=('a5856c72a6609a4dc68c88a7f3c33b79e6693343b62952e021e043fe347b6776'
+ 'df037766e3a152d8cf2a8b644dd10db8cac3679523adc3c063d41ffeb20d43bc')