summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMassimiliano Torromeo2017-04-06 12:29:51 +0200
committerMassimiliano Torromeo2017-04-06 12:29:51 +0200
commit9a804a887bf5d884c7d4b9d43451f6c859c46883 (patch)
treee393619a82581a627546da2090a8ede360ee827e
downloadaur-9a804a887bf5d884c7d4b9d43451f6c859c46883.tar.gz
Initial commit
-rw-r--r--.SRCINFO19
-rw-r--r--.gitignore17
-rw-r--r--PKGBUILD38
3 files changed, 74 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..bb2a396ef907
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+# Generated by mksrcinfo v8
+# Thu Apr 6 10:29:31 UTC 2017
+pkgbase = nginx-mainline-mod-passenger
+ pkgdesc = Fast and robust web server and application server for Ruby, Python and Node.js (module for mainline nginx)
+ pkgver = 5.1.2
+ pkgrel = 1
+ url = https://www.phusionpassenger.com
+ arch = i686
+ arch = x86_64
+ license = MIT
+ depends = nginx-mainline
+ depends = ruby
+ source = http://nginx.org/download/nginx-1.11.10.tar.gz
+ source = https://github.com/phusion/passenger/archive/release-5.1.2/passenger-5.1.2.tar.gz
+ sha256sums = 778b3cabb07633f754cd9dee32fc8e22582bce22bfa407be76a806abd935533d
+ sha256sums = 55c1d8748f362845da08b5a9f6f5c4ca1fafdad7a512866b05a1971f43674ca6
+
+pkgname = nginx-mainline-mod-passenger
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..9b97681014e9
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,17 @@
+*.zip
+*.jar
+*.tar
+*.tgz
+*.tbz2
+*.gz
+*.bz2
+*.xz
+*.gem
+*.run
+*.deb
+*.rpm
+*.sig
+*.log
+/src
+/pkg
+*.kate-swp
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8a99c210cabc
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+# Maintainer: Massimiliano Torromeo <massimiliano.torromeo@gmail.com>
+
+pkgname=nginx-mainline-mod-passenger
+pkgver=5.1.2
+pkgrel=1
+
+_modname="${pkgname#nginx-mainline-mod-}"
+_nginxver=1.11.10
+
+pkgdesc="Fast and robust web server and application server for Ruby, Python and Node.js (module for mainline nginx)"
+arch=('i686' 'x86_64')
+depends=('nginx-mainline' 'ruby')
+url="https://www.phusionpassenger.com"
+license=('MIT')
+
+source=(
+ http://nginx.org/download/nginx-$_nginxver.tar.gz
+ https://github.com/phusion/passenger/archive/release-$pkgver/$_modname-$pkgver.tar.gz
+)
+
+sha256sums=('778b3cabb07633f754cd9dee32fc8e22582bce22bfa407be76a806abd935533d'
+ '55c1d8748f362845da08b5a9f6f5c4ca1fafdad7a512866b05a1971f43674ca6')
+
+build() {
+ cd "$srcdir"/nginx-$_nginxver
+ ./configure $(nginx -V 2>&1 | grep 'configure arguments' | sed -r 's@^[^:]+: @@') --add-dynamic-module=../$_modname-release-$pkgver/src/nginx_module
+ make modules
+}
+
+package() {
+ install -Dm644 "$srcdir"/$_modname-release-$pkgver/LICENSE \
+ "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
+
+ cd "$srcdir"/nginx-$_nginxver/objs
+ for mod in ngx_*.so; do
+ install -Dm755 $mod "$pkgdir"/usr/lib/nginx/modules/$mod
+ done
+}