summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTrevor Bergeron2021-11-24 18:06:46 -0500
committerTrevor Bergeron2021-11-24 18:06:46 -0500
commit551619ba1900eb8e1b7976bcbd367aa807aca39c (patch)
tree1ecd1208afe8742667ec7ab0b5db702d5113e731
parent496cdb558e7d84181662e250214f34eb9dd10505 (diff)
downloadaur-551619ba1900eb8e1b7976bcbd367aa807aca39c.tar.gz
add aarch64, tidy
-rw-r--r--.SRCINFO12
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD12
3 files changed, 17 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 84ee112c3069..36b05cdebef9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,19 +1,19 @@
pkgbase = nginx-mainline-mod-rtmp
pkgdesc = Module for mainline nginx that adds RTMP support
pkgver = 1.2.2
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/arut/nginx-rtmp-module
+ arch = aarch64
arch = i686
arch = x86_64
license = BSD
depends = nginx-mainline
- source = http://nginx.org/download/nginx-1.19.10.tar.gz
- source = http://nginx.org/download/nginx-1.19.10.tar.gz.asc
- source = https://github.com/arut/nginx-rtmp-module/archive/v1.2.2.tar.gz
+ source = http://nginx.org/download/nginx-1.21.3.tar.gz
+ source = http://nginx.org/download/nginx-1.21.3.tar.gz.asc
+ source = nginx-rtmp-module-1.2.2.tar.gz::https://github.com/arut/nginx-rtmp-module/archive/v1.2.2.tar.gz
validpgpkeys = B0F4253373F8F6F510D42178520A9993A1C052F8
- sha256sums = SKIP
+ sha256sums = 14774aae0d151da350417efc4afda5cce5035056e71894836797e1f6e2d1175a
sha256sums = SKIP
sha256sums = 07f19b7bffec5e357bb8820c63e5281debd45f5a2e6d46b1636d9202c3e09d78
pkgname = nginx-mainline-mod-rtmp
-
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..cbb4585c5134
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+pkg/
+src/
+*.pkg.tar.zst
+*.tar.gz
+*.tar.gz.asc
diff --git a/PKGBUILD b/PKGBUILD
index aa1f2d6cafe6..881a5b55416f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,13 +2,13 @@
pkgname=nginx-mainline-mod-rtmp
pkgver=1.2.2
-pkgrel=1
+pkgrel=2
_modname="nginx-rtmp-module"
_nginxver="$(/bin/nginx -v 2>&1 | grep -Eo '([[:digit:]]|\.)+')"
pkgdesc="Module for mainline nginx that adds RTMP support"
-arch=('i686' 'x86_64')
+arch=('aarch64' 'i686' 'x86_64')
depends=('nginx-mainline')
url="https://github.com/arut/nginx-rtmp-module"
license=('BSD')
@@ -16,15 +16,15 @@ license=('BSD')
source=(
http://nginx.org/download/nginx-$_nginxver.tar.gz
http://nginx.org/download/nginx-$_nginxver.tar.gz.asc
- https://github.com/arut/$_modname/archive/v$pkgver.tar.gz
+ $_modname-$pkgver.tar.gz::https://github.com/arut/$_modname/archive/v$pkgver.tar.gz
)
-sha256sums=('SKIP'
+sha256sums=('14774aae0d151da350417efc4afda5cce5035056e71894836797e1f6e2d1175a'
'SKIP'
'07f19b7bffec5e357bb8820c63e5281debd45f5a2e6d46b1636d9202c3e09d78')
validpgpkeys=('B0F4253373F8F6F510D42178520A9993A1C052F8')
build() {
- cd "$srcdir"/nginx-$_nginxver
+ cd "$srcdir/nginx-$_nginxver"
# Cribbed from aur/nginx-mainline-mod-http-xslt-filter by Sergey Shatunov
opts=$(nginx -V 2>&1 | grep 'configure arguments' | sed -r 's@^[^:]+: @@')
@@ -35,7 +35,7 @@ build() {
}
package() {
- cd "$srcdir"/nginx-$_nginxver/objs
+ cd "$srcdir/nginx-$_nginxver/objs"
for mod in *.so; do
install -Dm755 $mod "$pkgdir"/usr/lib/nginx/modules/$mod
done