summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTrevor Bergeron2017-08-17 09:04:36 -0400
committerTrevor Bergeron2017-08-17 09:04:36 -0400
commitf9c5633619a3093dc0a1706e1bd3c2497f5ed491 (patch)
treede414b04b48c80fec5acea014dede270d07de09c
parent31bc8e8fff9eb7df8fe988744266597b1a5edf51 (diff)
downloadaur-f9c5633619a3093dc0a1706e1bd3c2497f5ed491.tar.gz
Bump pkgrel for nginx update, set SKIP
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD7
2 files changed, 6 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 67e6b4b3e0a5..cc0f53a83482 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = nginx-mainline-mod-rtmp
pkgdesc = Module for mainline nginx that adds RTMP support
pkgver = 1.2.0
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/arut/nginx-rtmp-module
arch = i686
arch = x86_64
@@ -11,7 +11,7 @@ pkgbase = nginx-mainline-mod-rtmp
source = http://nginx.org/download/nginx-1.13.3.tar.gz.asc
source = https://github.com/arut/nginx-rtmp-module/archive/v1.2.0.tar.gz
validpgpkeys = B0F4253373F8F6F510D42178520A9993A1C052F8
- sha256sums = 5b73f98004c302fb8e4a172abf046d9ce77739a82487e4873b39f9b0dcbb0d72
+ sha256sums = SKIP
sha256sums = SKIP
sha256sums = a8026f5ade30b178a06f12c46dff053cfe12256016ad465a46646183086b16b0
diff --git a/PKGBUILD b/PKGBUILD
index 0aa9ca6dc9f2..6884ad1f026b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=nginx-mainline-mod-rtmp
pkgver=1.2.0
-pkgrel=1
+pkgrel=2
_modname="nginx-rtmp-module"
_nginxver="$(/bin/nginx -v 2>&1 | grep -Eo '([[:digit:]]|\.)+')"
@@ -18,18 +18,19 @@ source=(
http://nginx.org/download/nginx-$_nginxver.tar.gz.asc
https://github.com/arut/$_modname/archive/v$pkgver.tar.gz
)
-sha256sums=('5b73f98004c302fb8e4a172abf046d9ce77739a82487e4873b39f9b0dcbb0d72'
+sha256sums=('SKIP'
'SKIP'
'a8026f5ade30b178a06f12c46dff053cfe12256016ad465a46646183086b16b0')
validpgpkeys=('B0F4253373F8F6F510D42178520A9993A1C052F8')
build() {
cd "$srcdir"/nginx-$_nginxver
- #./configure $(nginx -V 2>&1 | grep 'configure arguments' | sed -r 's@^[^:]+: @@') --add-dynamic-module=../$_modname-$pkgver
+
# Cribbed from aur/nginx-mainline-mod-http-xslt-filter by Sergey Shatunov
opts=$(nginx -V 2>&1 | grep 'configure arguments' | sed -r 's@^[^:]+: @@')
IFS=$'\n' opts=( $(xargs -n1 <<< "$opts") )
./configure "${opts[@]}" --add-dynamic-module=../$_modname-$pkgver
+
make modules
}