summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMassimiliano Torromeo2017-03-10 13:30:04 +0100
committerMassimiliano Torromeo2017-03-10 13:30:04 +0100
commit27c4b51e4e21988e7014e6b75e75b2727c6e921e (patch)
treeef5254e2a0c94678e7bbf388f03867b35ce03816
downloadaur-27c4b51e4e21988e7014e6b75e75b2727c6e921e.tar.gz
Initial commit
-rw-r--r--.SRCINFO18
-rw-r--r--.gitignore17
-rw-r--r--PKGBUILD35
3 files changed, 70 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..78276fb84e73
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+# Generated by mksrcinfo v8
+# Fri Mar 10 12:29:46 UTC 2017
+pkgbase = nginx-mainline-addon-srcache
+ pkgdesc = Transparent subrequest-based caching layout for arbitrary nginx locations (module for mainline nginx)
+ pkgver = 0.31
+ pkgrel = 1
+ url = https://github.com/openresty/srcache-nginx-module
+ arch = i686
+ arch = x86_64
+ license = BSD
+ depends = nginx-mainline
+ source = http://nginx.org/download/nginx-1.11.10.tar.gz
+ source = https://github.com/openresty/srcache-nginx-module/archive/v0.31/srcache-0.31.tar.gz
+ sha256sums = 778b3cabb07633f754cd9dee32fc8e22582bce22bfa407be76a806abd935533d
+ sha256sums = 3f9729e73a8340926fa9d9fc15707c2f287cd27b6a9fe42e83f660ca48a5972d
+
+pkgname = nginx-mainline-addon-srcache
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..9b97681014e9
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,17 @@
+*.zip
+*.jar
+*.tar
+*.tgz
+*.tbz2
+*.gz
+*.bz2
+*.xz
+*.gem
+*.run
+*.deb
+*.rpm
+*.sig
+*.log
+/src
+/pkg
+*.kate-swp
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6a1caf5efcc9
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: Massimiliano Torromeo <massimiliano.torromeo@gmail.com>
+
+pkgname=nginx-mainline-addon-srcache
+pkgver=0.31
+pkgrel=1
+
+_modname="${pkgname#nginx-mainline-addon-}"
+_nginxver=1.11.10
+
+pkgdesc='Transparent subrequest-based caching layout for arbitrary nginx locations (module for mainline nginx)'
+arch=('i686' 'x86_64')
+depends=('nginx-mainline')
+url="https://github.com/openresty/srcache-nginx-module"
+license=('BSD')
+
+source=(
+ http://nginx.org/download/nginx-$_nginxver.tar.gz
+ https://github.com/openresty/$_modname-nginx-module/archive/v$pkgver/$_modname-$pkgver.tar.gz
+)
+
+sha256sums=('778b3cabb07633f754cd9dee32fc8e22582bce22bfa407be76a806abd935533d'
+ '3f9729e73a8340926fa9d9fc15707c2f287cd27b6a9fe42e83f660ca48a5972d')
+
+build() {
+ cd "$srcdir"/nginx-$_nginxver
+ ./configure $(nginx -V 2>&1 | grep 'configure arguments' | sed -r 's@^[^:]+: @@') --add-dynamic-module=../$_modname-nginx-module-$pkgver
+ make modules
+}
+
+package() {
+ cd "$srcdir"/nginx-$_nginxver/objs
+ for mod in *.so; do
+ install -Dm755 $mod "$pkgdir"/usr/lib/nginx/modules/$mod
+ done
+}