summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorIvan Shapovalov2021-09-15 17:47:05 +0300
committerIvan Shapovalov2021-09-15 17:47:05 +0300
commit51e7b1e5b059d948cca09f82ee2eb1cb138f7833 (patch)
tree52b36f9556dac0825568ca60a3f745b2ef65b20e
parent0143d3f8667b8e27a8b348d3bfc36030cce5682a (diff)
downloadaur-51e7b1e5b059d948cca09f82ee2eb1cb138f7833.tar.gz
Build for nginx 1.21.3
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD9
2 files changed, 9 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c89b84d31ca2..2b211551b782 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,15 @@
pkgbase = nginx-mainline-mod-vts
pkgdesc = Nginx virtual host traffic status module (module for mainline nginx)
pkgver = 0.1.18
- pkgrel = 30
+ pkgrel = 33
url = https://github.com/vozlt/nginx-module-vts
arch = i686
arch = x86_64
license = BSD
- depends = nginx-mainline=1.21.0
- source = https://nginx.org/download/nginx-1.21.0.tar.gz
+ source = https://nginx.org/download/nginx-1.21.3.tar.gz
source = nginx-mainline-mod-vts-0.1.18.tar.gz::https://github.com/vozlt/nginx-module-vts/archive/v0.1.18.tar.gz
- sha256sums = fe192a4bac2bd3a769e8695cb9fe14a00e57eaceb919095347a83b5b2afc0771
+ sha256sums = 31771c560e46d73650568e8193cb94d981081f83dd62d1ba43af1a1e0ba25185
sha256sums = 17ea41d4083f6d1ab1ab83dad9160eeca66867abe16c5a0421f85a39d7c84b65
pkgname = nginx-mainline-mod-vts
+ depends = nginx-mainline=1.21.3
diff --git a/PKGBUILD b/PKGBUILD
index aad53ac4ce82..e14826b823d0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,14 +3,14 @@
pkgname=nginx-mainline-mod-vts
pkgver=0.1.18
-pkgrel=30
+pkgrel=33
_modname="${pkgname#nginx-mainline-mod-}"
-_nginxver=1.21.0
+_nginxver=1.21.3
pkgdesc='Nginx virtual host traffic status module (module for mainline nginx)'
arch=('i686' 'x86_64')
-depends=("nginx-mainline=$_nginxver")
+depends=() # the build process doesn't require or use installed nginx, so add the dependency in package() to break the cycle
url="https://github.com/vozlt/nginx-module-vts"
license=('BSD')
@@ -19,7 +19,7 @@ source=(
$pkgname-$pkgver.tar.gz::https://github.com/vozlt/nginx-module-vts/archive/v$pkgver.tar.gz
)
-sha256sums=('fe192a4bac2bd3a769e8695cb9fe14a00e57eaceb919095347a83b5b2afc0771'
+sha256sums=('31771c560e46d73650568e8193cb94d981081f83dd62d1ba43af1a1e0ba25185'
'17ea41d4083f6d1ab1ab83dad9160eeca66867abe16c5a0421f85a39d7c84b65')
build() {
@@ -29,6 +29,7 @@ build() {
}
package() {
+ depends=("nginx-mainline=$_nginxver")
install -Dm644 "$srcdir"/nginx-module-vts-$pkgver/LICENSE \
"$pkgdir"/usr/share/licenses/$pkgname/LICENSE