summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorHaruue Icymoon2017-12-07 15:54:11 +0800
committerHaruue Icymoon2017-12-07 15:54:11 +0800
commit1653fae81e1eae75711778b5a0a234bd16a1fdda (patch)
tree130dcbf5b677c3d8bbd5b4aeb1eb936bd5b40efd
downloadaur-1653fae81e1eae75711778b5a0a234bd16a1fdda.tar.gz
init: nginx-mod-ct
Signed-off-by: Haruue Icymoon <haruue@caoyue.com.cn>
-rw-r--r--.SRCINFO15
-rw-r--r--.gitignore3
-rw-r--r--PKGBUILD38
3 files changed, 56 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1e1600e08cf9
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = nginx-mod-ct
+ pkgdesc = Nginx module that provides Certificate Transparency supports
+ pkgver = 1.3.2
+ pkgrel = 1
+ url = https://github.com/grahamedgecombe/nginx-ct
+ arch = x86_64
+ license = ISC
+ depends = nginx=1.12.2
+ source = https://nginx.org/download/nginx-1.12.2.tar.gz
+ source = nginx-ct-1.3.2.tar.gz::https://github.com/grahamedgecombe/nginx-ct/archive/v1.3.2.tar.gz
+ sha256sums = SKIP
+ sha256sums = b4ceae549b9dbf84b2e511633982e4efeee0388e3b7a038a8bac555008a77b88
+
+pkgname = nginx-mod-ct
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..f9e46d035853
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,3 @@
+*.tar.*
+/src
+/pkg
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4facaca6e387
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+# Maintainer: Haruue Icymoon <i@haruue.moe>
+
+pkgname=nginx-mod-ct
+pkgver=1.3.2
+pkgrel=1
+
+_nginxver=1.12.2
+
+pkgdesc='Nginx module that provides Certificate Transparency supports'
+arch=('x86_64')
+depends=("nginx=$_nginxver")
+url="https://github.com/grahamedgecombe/nginx-ct"
+license=('ISC')
+
+source=(
+ https://nginx.org/download/nginx-$_nginxver.tar.gz
+ "nginx-ct-$pkgver.tar.gz"::"https://github.com/grahamedgecombe/nginx-ct/archive/v$pkgver.tar.gz"
+)
+sha256sums=('SKIP'
+'b4ceae549b9dbf84b2e511633982e4efeee0388e3b7a038a8bac555008a77b88')
+
+build() {
+ cd "$srcdir"/nginx-$_nginxver
+ ./configure --with-compat --with-http_ssl_module --add-dynamic-module=../nginx-ct-$pkgver
+ make modules
+}
+
+package() {
+ install -Dm644 "$srcdir/"nginx-ct-$pkgver/LICENSE \
+ "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
+
+ cd "$srcdir"/nginx-$_nginxver/objs
+ for mod in *.so; do
+ install -Dm755 $mod "$pkgdir"/usr/lib/nginx/modules/$mod
+ done
+}
+
+# vim:set ts=8 sts=2 sw=2 et: