summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorfunilrys2024-02-08 20:33:04 +0100
committerfunilrys2024-02-08 20:33:04 +0100
commit8a9e0d8b377eb81707551a2283bfee2c12e3c204 (patch)
treea86d2f452ffcfe316a35ef63b21c0bbc2f3b09fc
parent170c341f5e53c0438d8ba516eee3887f420f8357 (diff)
downloadaur-nginx-mod-echo-git.tar.gz
Update nginx-mod-echo-git.
This patch switch to pure git guidelines.
-rwxr-xr-x.SRCINFO14
-rwxr-xr-xPKGBUILD17
2 files changed, 16 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 56cc692183c4..d2692044f011 100755
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,16 @@
pkgbase = nginx-mod-echo-git
pkgdesc = Nginx module that brings shell-style goodiesto nginx config file
- pkgver = 0.60
- pkgrel = 3
+ pkgver = 0.63
+ pkgrel = 4
url = https://github.com/openresty/echo-nginx-module
arch = i686
arch = x86_64
license = custom
makedepends = git
- depends = nginx=1.10.0
- source = https://github.com/openresty/echo-nginx-module/archive/0.60.tar.gz http://nginx.org/download/nginx-1.10.0.tar.gz
- md5sums = 897338c2c4bc44f2d56ae06ab9820372
- md5sums = c184c873d2798c5ba92be95ed1209c02
+ depends = nginx=1.24.0
+ source = git+https://github.com/openresty/echo-nginx-module.git
+ source = http://nginx.org/download/nginx-1.24.0.tar.gz
+ md5sums = SKIP
+ md5sums = f95835b55b3cbf05a4368e7bccbb8a46
pkgname = nginx-mod-echo-git
-
diff --git a/PKGBUILD b/PKGBUILD
index 3513cd24e9fe..927c901e95f8 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,22 +1,23 @@
# Maintainer: Nissar Chababy <funilrys at outlook dot com>
# Ex-Maintainer: Bartłomiej Piotrowski <bpiotrowski@archlinux.org>
-_ngx_ver=1.10.0
+_ngx_ver=1.24.0
_mod_name=echo
pkgname=nginx-mod-${_mod_name}-git
-pkgver=0.60
-pkgrel=3
+pkgver=0.63
+pkgrel=1
pkgdesc='Nginx module that brings shell-style goodiesto nginx config file'
arch=('i686' 'x86_64')
url='https://github.com/openresty/echo-nginx-module'
license=('custom')
depends=("nginx=$_ngx_ver")
makedepends=('git')
-source=("https://github.com/openresty/${_mod_name}-nginx-module/archive/${pkgver}.tar.gz
- http://nginx.org/download/nginx-${_ngx_ver}.tar.gz")
-md5sums=('897338c2c4bc44f2d56ae06ab9820372'
- 'c184c873d2798c5ba92be95ed1209c02')
+
+source=("git+https://github.com/openresty/${_mod_name}-nginx-module.git"
+ "http://nginx.org/download/nginx-${_ngx_ver}.tar.gz")
+md5sums=('SKIP'
+ 'f95835b55b3cbf05a4368e7bccbb8a46')
_ngx_flags=(
--with-file-aio
@@ -46,7 +47,7 @@ _ngx_flags=(
pkgver() {
cd ${_mod_name}-nginx-module
- git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g;s/^v//'
+ git describe --long --tags --abbrev=7 | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
}
build() {