summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Weiman2017-09-22 23:08:34 -0400
committerMark Weiman2017-09-22 23:08:34 -0400
commit9a2e1786625443ffd1859a4a03bec84e4be135ff (patch)
tree5eef859c9701ac59d324a4ac3fbc134b6a43a01d
downloadaur-9a2e1786625443ffd1859a4a03bec84e4be135ff.tar.gz
Initial commit (0.4.2-1)
-rw-r--r--.SRCINFO20
-rw-r--r--.gitignore3
-rw-r--r--PKGBUILD40
3 files changed, 63 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..df9df7b280e7
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+# Generated by mksrcinfo v8
+# Sat Sep 23 03:08:17 UTC 2017
+pkgbase = nginx-mod-fancyindex
+ pkgdesc = Fancy indexes module for the Nginx web server
+ pkgver = 0.4.2
+ pkgrel = 1
+ url = https://github.com/aperezdc/ngx-fancyindex
+ arch = i686
+ arch = x86_64
+ license = BSD
+ depends = nginx
+ source = https://nginx.org/download/nginx-1.12.1.tar.gz
+ source = https://nginx.org/download/nginx-1.12.1.tar.gz.asc
+ source = https://github.com/aperezdc/ngx-fancyindex/archive/v0.4.2.tar.gz
+ md5sums = a307e74aca95403e5ee00f153807ce58
+ md5sums = SKIP
+ md5sums = fc2154f36eeabae4d4855cfcc25a060f
+
+pkgname = nginx-mod-fancyindex
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..a1aa878196ae
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,3 @@
+*z
+pkg
+src
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3c35d4c82516
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,40 @@
+# Maintainer: Mark Weiman <mark.weiman@markzz.com>
+# Contributor: hdhoang <arch@hdhoang.space>
+
+pkgname=nginx-mod-fancyindex
+pkgver=0.4.2
+pkgrel=1
+
+_modname="${pkgname#nginx-mod-}"
+_nginxver=1.12.1
+
+pkgdesc='Fancy indexes module for the Nginx web server'
+arch=('i686' 'x86_64')
+depends=('nginx')
+url="https://github.com/aperezdc/ngx-fancyindex"
+license=('BSD')
+
+source=(https://nginx.org/download/nginx-$_nginxver.tar.gz{,.asc}
+ https://github.com/aperezdc/ngx-$_modname/archive/v$pkgver.tar.gz
+)
+validpgpkeys=(B0F4253373F8F6F510D42178520A9993A1C052F8) # Maxim Dounin <mdounin@mdounin.ru>
+md5sums=('a307e74aca95403e5ee00f153807ce58'
+ 'SKIP'
+ 'fc2154f36eeabae4d4855cfcc25a060f')
+
+build() {
+ cd "$srcdir"/nginx-$_nginxver
+ ./configure --with-compat --add-dynamic-module=../ngx-$_modname-$pkgver
+ make modules
+}
+
+package() {
+ install -Dm644 "$srcdir/"ngx-$_modname-$pkgver/LICENSE \
+ "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
+
+ cd "$srcdir"/nginx-$_nginxver/objs
+ for mod in *.so; do
+ install -Dm755 $mod "$pkgdir"/usr/lib/nginx/modules/$mod
+ done
+}
+