summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSebastian 'Swift Geek' Grzywna2018-01-18 01:03:50 +0100
committerSebastian 'Swift Geek' Grzywna2018-01-18 01:03:50 +0100
commitcbc6370e2a27f8edd8f65d1424a8039321453dbb (patch)
tree3ae0fe432ad87b68bf271a06869f5386c492a1f4
downloadaur-cbc6370e2a27f8edd8f65d1424a8039321453dbb.tar.gz
Initial commit
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD37
2 files changed, 55 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..827b3d6a82d9
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+# Generated by mksrcinfo v8
+# Thu Jan 18 00:03:27 UTC 2018
+pkgbase = nginx-mod-http-knock
+ pkgdesc = Nginx module ngx_http_knock_module to guard websites with a secret handshake
+ pkgver = a
+ pkgrel = 1
+ url = https://github.com/PhillipTaylor/ngx_http_knock_module
+ arch = i686
+ arch = x86_64
+ license = MIT
+ depends = nginx
+ source = https://nginx.org/download/nginx-1.13.4.tar.gz
+ source = git+https://github.com/PhillipTaylor/ngx_http_knock_module.git
+ sha256sums = de21f3c49ba65c611329d8759a63d72e5fcf719bc6f2a3270e2541348ef1fbba
+ sha256sums = SKIP
+
+pkgname = nginx-mod-http-knock
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5cd7830dce3e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+#TODO: pkgver
+#TODO: fetch version of nginx automatically
+#TODO: any hook for nginx upgrades?
+#TODO: add nginx vesrion to pkgver - nginxver-pkgver
+pkgname=nginx-mod-http-knock
+pkgver=a
+pkgrel=1
+
+_modname=ngx_http_knock_module
+_nginxver=1.13.4
+
+pkgdesc='Nginx module ngx_http_knock_module to guard websites with a secret handshake'
+arch=('i686' 'x86_64')
+depends=('nginx')
+url="https://github.com/PhillipTaylor/ngx_http_knock_module"
+license=('MIT')
+
+source=(
+ "https://nginx.org/download/nginx-$_nginxver.tar.gz"
+ "git+https://github.com/PhillipTaylor/ngx_http_knock_module.git"
+)
+
+sha256sums=('de21f3c49ba65c611329d8759a63d72e5fcf719bc6f2a3270e2541348ef1fbba'
+ 'SKIP')
+
+build() {
+ cd "$srcdir"/nginx-$_nginxver
+ ./configure --with-compat --add-dynamic-module=../$_modname
+ make modules
+}
+
+package() {
+ cd "$srcdir"/nginx-$_nginxver/objs
+ for mod in *.so; do
+ install -Dm755 $mod "$pkgdir"/usr/lib/nginx/modules/$mod
+ done
+}