summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorThecaTTony2020-01-07 00:15:38 -0300
committerThecaTTony2020-01-07 00:15:38 -0300
commit0f33131c6fabc38f79c80ba327664186e457661e (patch)
treebfc926262b8608d2a35eb04f7035dbcfffeeeed8
downloadaur-0f33131c6fabc38f79c80ba327664186e457661e.tar.gz
Initial commit
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD36
2 files changed, 55 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..710045bb6059
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = nginx-mod-length-hiding-filter
+ pkgdesc = Nginx module to append random generated string to the end of HTML response
+ pkgver = 1.1.1
+ pkgrel = 1
+ url = https://github.com/nulab/nginx-length-hiding-filter-module
+ arch = x86_64
+ arch = arm
+ arch = armv6h
+ arch = armv7h
+ arch = aarch64
+ license = MIT
+ depends = nginx
+ source = https://nginx.org/download/nginx-1.16.1.tar.gz
+ source = https://github.com/nulab/nginx-length-hiding-filter-module/archive/1.1.1.tar.gz
+ sha512sums = 17e95b43fa47d4fef5e652dea587518e16ab5ec562c9c94355c356440166d4b6a6a41ee520d406e5a34791a327d2e3c46b3f9b105ac9ce07afdd495c49eca437
+ sha512sums = 3eebd28808241daf26081126249174704a08aca9c0ff42e00875f7439de49e53e3cdb40e956e388ccb8b8bd5fff0103e97f6f38aa0d84d22f2f6f56295f60bec
+
+pkgname = nginx-mod-length-hiding-filter
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..18137e33dd75
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# Maintainer: ThecaTTony <thecattony at gmx dot com>
+
+pkgname=nginx-mod-length-hiding-filter
+pkgver=1.1.1
+pkgrel=1
+
+_modname=nginx-length-hiding-filter-module
+_nginxver=1.16.1
+
+pkgdesc='Nginx module to append random generated string to the end of HTML response'
+arch=('x86_64' 'arm' 'armv6h' 'armv7h' 'aarch64')
+depends=('nginx')
+url='https://github.com/nulab/nginx-length-hiding-filter-module'
+license=('MIT')
+
+source=(https://nginx.org/download/nginx-$_nginxver.tar.gz
+ https://github.com/nulab/nginx-length-hiding-filter-module/archive/$pkgver.tar.gz)
+
+sha512sums=('17e95b43fa47d4fef5e652dea587518e16ab5ec562c9c94355c356440166d4b6a6a41ee520d406e5a34791a327d2e3c46b3f9b105ac9ce07afdd495c49eca437'
+ '3eebd28808241daf26081126249174704a08aca9c0ff42e00875f7439de49e53e3cdb40e956e388ccb8b8bd5fff0103e97f6f38aa0d84d22f2f6f56295f60bec')
+
+build() {
+ cd "$srcdir"/nginx-"$_nginxver"
+ opts=$(nginx -V 2>&1 | grep 'configure arguments' | sed -r 's@^[^:]+: @@')
+ IFS=$'\n' opts=( $(xargs -n1 <<< "$opts") )
+ ./configure "${opts[@]}" \
+ --add-dynamic-module=../"$_modname"-"$pkgver"
+ make modules
+}
+
+package() {
+ cd "$srcdir"/nginx-"$_nginxver"/objs
+ for mod in *.so; do
+ install -Dm755 $mod "$pkgdir"/usr/lib/nginx/modules/$mod
+ done
+}