summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJakob (XDjackieXD) Riepler2018-03-31 22:32:04 +0200
committerJakob (XDjackieXD) Riepler2018-03-31 22:32:04 +0200
commitfc32f201b9e79da48409093d10f596ca3a462a9b (patch)
tree81c396299461add896e6f0f7e6f0ff464c0540ae
downloadaur-fc32f201b9e79da48409093d10f596ca3a462a9b.tar.gz
Initial Commit
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD40
2 files changed, 59 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f6c1871edc16
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = nginx-mod-rtmp
+ pkgdesc = Module for nginx that adds RTMP support
+ pkgver = 1.2.1
+ pkgrel = 1
+ url = https://github.com/arut/nginx-rtmp-module
+ arch = i686
+ arch = x86_64
+ license = BSD
+ depends = nginx
+ source = http://nginx.org/download/nginx-9.tar.gz
+ source = http://nginx.org/download/nginx-9.tar.gz.asc
+ source = https://github.com/arut/nginx-rtmp-module/archive/v1.2.1.tar.gz
+ validpgpkeys = B0F4253373F8F6F510D42178520A9993A1C052F8
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = 87aa597400b0b5a05274ee2d23d8cb8224e12686227a0abe31d783b3a645ea37
+
+pkgname = nginx-mod-rtmp
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c3acb80cb6c8
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,40 @@
+# Maintainer: Jakob Riepler <aur@chaosfield.at>
+# Contributor: Trevor Bergeron <aur@sec.gd>
+
+pkgname=nginx-mod-rtmp
+pkgver=1.2.1
+pkgrel=1
+
+_modname="nginx-rtmp-module"
+_nginxver="$(/bin/nginx -v 2>&1 | grep -Eo '([[:digit:]]|\.)+')"
+
+pkgdesc="Module for nginx that adds RTMP support"
+arch=('i686' 'x86_64')
+depends=('nginx')
+url="https://github.com/arut/nginx-rtmp-module"
+license=('BSD')
+
+source=(
+ http://nginx.org/download/nginx-$_nginxver.tar.gz
+ http://nginx.org/download/nginx-$_nginxver.tar.gz.asc
+ https://github.com/arut/$_modname/archive/v$pkgver.tar.gz
+)
+sha256sums=('SKIP'
+ 'SKIP'
+ '87aa597400b0b5a05274ee2d23d8cb8224e12686227a0abe31d783b3a645ea37')
+validpgpkeys=('B0F4253373F8F6F510D42178520A9993A1C052F8')
+
+build() {
+ cd "$srcdir"/nginx-$_nginxver
+
+ ./configure --with-compat --add-dynamic-module=../$_modname-$pkgver
+
+ make modules
+}
+
+package() {
+ cd "$srcdir"/nginx-$_nginxver/objs
+ for mod in *.so; do
+ install -Dm755 $mod "$pkgdir"/usr/lib/nginx/modules/$mod
+ done
+}