summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorwobbol2019-04-06 15:25:51 -0500
committerwobbol2019-04-06 15:34:42 -0500
commit4634f0cf734d71460c162e2fcd4bd25dcfac429b (patch)
tree0466ca83d7dbbc7a3363025f957de7a9ca19ae74
downloadaur-4634f0cf734d71460c162e2fcd4bd25dcfac429b.tar.gz
Point to more recent sources
- github.com/arut's sources are too old - the dash spec has changed time formats - arut hasn't commited to this module since 2017 - github.com/sergey-dryabzhinsky's latest tag is too old - the openssl that ships on arch is incompatable with those sources - Patching new openssl support seems non-trivial - using github.com/sergey-dryabzhinsky's dev branch - many people seem to be using this branch without any problem - the author is pretty adament about this branch being unstable - there have been no commits to master since 2016 - the version tags seem to be on the dev branch anyway - I don't like it, but it is the best option right now. - Fixes - variable expansions with double quotes - seperate the ./configure into prepare()
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD51
2 files changed, 70 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..3665f11f254d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = nginx-mod-rtmp-git
+ pkgdesc = Module for nginx that adds RTMP support
+ pkgver = 1196.a5ac72c
+ pkgrel = 1
+ url = https://github.com/sergey-dryabzhinsky/nginx-rtmp-module
+ arch = i686
+ arch = x86_64
+ license = BSD
+ depends = nginx
+ source = http://nginx.org/download/nginx-1.14.2.tar.gz
+ source = http://nginx.org/download/nginx-1.14.2.tar.gz.asc
+ source = nginx-rtmp-module::git+https://github.com/sergey-dryabzhinsky/nginx-rtmp-module.git
+ validpgpkeys = B0F4253373F8F6F510D42178520A9993A1C052F8
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
+
+pkgname = nginx-mod-rtmp-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6cdf37b130ca
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,51 @@
+# Maintainer: wobbol <no@spam.com>
+# Contributor: Jakob Riepler <aur@chaosfield.at>
+# Contributor: Trevor Bergeron <aur@sec.gd>
+
+pkgname=nginx-mod-rtmp-git
+pkgver=1196.a5ac72c
+pkgrel=1
+
+_modname="nginx-rtmp-module"
+_nginxver="$(/bin/nginx -v 2>&1 | grep -Eo '([[:digit:]]|\.)+')"
+
+pkgdesc="Module for nginx that adds RTMP support"
+arch=('i686' 'x86_64')
+depends=('nginx')
+url="https://github.com/sergey-dryabzhinsky/nginx-rtmp-module"
+license=('BSD')
+
+source=(
+ "http://nginx.org/download/nginx-$_nginxver.tar.gz"
+ "http://nginx.org/download/nginx-$_nginxver.tar.gz.asc"
+ "$_modname::git+https://github.com/sergey-dryabzhinsky/nginx-rtmp-module.git"
+)
+sha256sums=(
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+)
+
+validpgpkeys=('B0F4253373F8F6F510D42178520A9993A1C052F8')
+
+pkgver() {
+ cd "$_modname"
+ printf "%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+prepare() {
+ cd "nginx-$_nginxver"
+ ./configure --with-compat --add-dynamic-module="../$_modname"
+}
+
+build() {
+ cd "nginx-$_nginxver"
+ make modules
+}
+
+package() {
+ cd "nginx-$_nginxver/objs"
+ for mod in *.so; do
+ install -Dm755 "$mod" "$pkgdir/usr/lib/nginx/modules/$mod"
+ done
+}