summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorwobbol2019-04-06 17:49:00 -0500
committerwobbol2019-04-06 17:49:00 -0500
commitbe4198fe6333e6cde04767bafb54e7b63ea992a1 (patch)
tree8b3dd912a929222d751ae084ee15b1372b5cecbc
parent4853c7482bc48f296993c34079356983e8cef041 (diff)
downloadaur-be4198fe6333e6cde04767bafb54e7b63ea992a1.tar.gz
Add provides, revert prepare(), simplify package()
- Add provides - Other AUR packages exist that provide this same module. - No other nginx-mod-* package lists this so it is pretty much useless. - Revert prepare() - Apparently, prepare() is for patches not ./configure - Simplify package() - No need for a loop we just have one file. - Update package description. - This package has far more than rtmp in it.
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD28
2 files changed, 15 insertions, 17 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3665f11f254d..1b098d42bb0b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,5 +1,5 @@
pkgbase = nginx-mod-rtmp-git
- pkgdesc = Module for nginx that adds RTMP support
+ pkgdesc = Module for nginx that adds RTMP, HLS, and MPEG-DASH support.
pkgver = 1196.a5ac72c
pkgrel = 1
url = https://github.com/sergey-dryabzhinsky/nginx-rtmp-module
@@ -7,6 +7,8 @@ pkgbase = nginx-mod-rtmp-git
arch = x86_64
license = BSD
depends = nginx
+ depends = openssl
+ provides = nginx-rtmp-module
source = http://nginx.org/download/nginx-1.14.2.tar.gz
source = http://nginx.org/download/nginx-1.14.2.tar.gz.asc
source = nginx-rtmp-module::git+https://github.com/sergey-dryabzhinsky/nginx-rtmp-module.git
diff --git a/PKGBUILD b/PKGBUILD
index 02d86ce7e068..f3b1c34acc75 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,10 +9,11 @@ pkgrel=1
_modname="nginx-rtmp-module"
_nginxver="$(/bin/nginx -v 2>&1 | grep -Eo '([[:digit:]]|\.)+')"
-pkgdesc="Module for nginx that adds RTMP support"
+pkgdesc='Module for nginx that adds RTMP, HLS, and MPEG-DASH support.'
arch=('i686' 'x86_64')
-depends=('nginx')
-url="https://github.com/sergey-dryabzhinsky/nginx-rtmp-module"
+depends=('nginx' 'openssl')
+provides=("$_modname")
+url='https://github.com/sergey-dryabzhinsky/nginx-rtmp-module'
license=('BSD')
source=(
@@ -25,7 +26,7 @@ sha256sums=(
'SKIP'
'SKIP'
)
-
+# Maxim Dounin <mdounin@mdounin.ru>
validpgpkeys=('B0F4253373F8F6F510D42178520A9993A1C052F8')
pkgver() {
@@ -33,20 +34,15 @@ pkgver() {
printf "%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
-prepare() {
- cd "nginx-$_nginxver"
- ./configure --with-compat --add-dynamic-module="../$_modname"
-}
-
build() {
- cd "nginx-$_nginxver"
- make modules
+ cd "nginx-$_nginxver"
+ ./configure --with-compat "--add-dynamic-module=../$_modname"
+ make modules
}
package() {
- install -Dm644 "$_modname/LICENSE" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
- cd "nginx-$_nginxver/objs"
- for mod in *.so; do
- install -Dm755 "$mod" "$pkgdir/usr/lib/nginx/modules/$mod"
- done
+ cd "$_modname"
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ cd "../nginx-$_nginxver/objs"
+ install -Dm755 ngx_rtmp_module.so "$pkgdir/usr/lib/nginx/modules/ngx_rtmp_module.so"
}