summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLaura Hausmann2021-01-24 18:20:40 +0100
committerLaura Hausmann2021-01-24 18:21:06 +0100
commitd69ef3be72dee94d0c2c434457c1748a833485eb (patch)
tree7b863fe251084a99aa8849b61ba85a468e60f736
downloadaur-d69ef3be72dee94d0c2c434457c1748a833485eb.tar.gz
Add package
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD49
2 files changed, 70 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..dc96624e4a13
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = nginx-mod-rtmp-lhaus-git
+ pkgdesc = Module for nginx that adds RTMP, HLS, and MPEG-DASH support. lhaus fork.
+ pkgver = 1207.8aa8f06
+ pkgrel = 1
+ url = https://github.com/lhaus/nginx-rtmp-module
+ arch = i686
+ arch = x86_64
+ license = BSD
+ depends = nginx
+ depends = openssl
+ provides = nginx-rtmp-module
+ source = http://nginx.org/download/nginx-11.tar.gz
+ source = http://nginx.org/download/nginx-11.tar.gz.asc
+ source = nginx-rtmp-module::git+https://github.com/lhaus/nginx-rtmp-module.git#branch=dev
+ validpgpkeys = B0F4253373F8F6F510D42178520A9993A1C052F8
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
+
+pkgname = nginx-mod-rtmp-lhaus-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c58e851c5f18
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,49 @@
+# Maintainer: zotan <aur@zotan.email>
+# Contributor: wobbol <no@spam.com>
+# Contributor: Jakob Riepler <aur@chaosfield.at>
+# Contributor: Trevor Bergeron <aur@sec.gd>
+
+pkgname=nginx-mod-rtmp-lhaus-git
+pkgver=1207.8aa8f06
+pkgrel=1
+
+_modname="nginx-rtmp-module"
+_nginxver="$(/bin/nginx -v 2>&1 | grep -Eo '([[:digit:]]|\.)+')"
+
+pkgdesc='Module for nginx that adds RTMP, HLS, and MPEG-DASH support. lhaus fork.'
+arch=('i686' 'x86_64')
+depends=('nginx' 'openssl')
+provides=("$_modname")
+url='https://github.com/lhaus/nginx-rtmp-module'
+license=('BSD')
+
+source=(
+ "http://nginx.org/download/nginx-$_nginxver.tar.gz"
+ "http://nginx.org/download/nginx-$_nginxver.tar.gz.asc"
+ "$_modname::git+https://github.com/lhaus/nginx-rtmp-module.git#branch=dev"
+)
+sha256sums=(
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+)
+# Maxim Dounin <mdounin@mdounin.ru>
+validpgpkeys=('B0F4253373F8F6F510D42178520A9993A1C052F8')
+
+pkgver() {
+ cd "$_modname"
+ printf "%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd "nginx-$_nginxver"
+ ./configure --with-compat "--add-dynamic-module=../$_modname"
+ make modules
+}
+
+package() {
+ cd "$_modname"
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ cd "../nginx-$_nginxver/objs"
+ install -Dm755 ngx_rtmp_module.so "$pkgdir/usr/lib/nginx/modules/ngx_rtmp_module.so"
+}