summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorYUP2019-05-20 16:10:59 +0200
committerYUP2019-05-20 16:10:59 +0200
commit77d37e0bd6363700e8489b88adf70ff2061173a8 (patch)
tree1dadc3e789dffc272975dd5c25dfee2227cf2ac9
downloadaur-77d37e0bd6363700e8489b88adf70ff2061173a8.tar.gz
Initial version
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD36
2 files changed, 54 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..261126b005bb
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = nginx-mod-rtmpt-proxy
+ pkgdesc = Module for nginx that adds RTMP support
+ pkgver = 1.0.0
+ pkgrel = 1
+ url = https://github.com/kwojtek/nginx-rtmpt-proxy-module.git
+ arch = i686
+ arch = x86_64
+ license = BSD
+ depends = nginx
+ source = http://nginx.org/download/nginx-1.16.0.tar.gz
+ source = http://nginx.org/download/nginx-1.16.0.tar.gz.asc
+ source = https://github.com/kwojtek/nginx-rtmpt-proxy-module/archive/master.zip
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
+
+pkgname = nginx-mod-rtmpt-proxy
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..dd61c756e739
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+
+pkgname=nginx-mod-rtmpt-proxy
+pkgver=1.0.0
+pkgrel=1
+
+_modname="nginx-rtmpt-proxy-module"
+_nginxver="$(/bin/nginx -v 2>&1 | grep -Eo '([[:digit:]]|\.)+')"
+
+pkgdesc="Module for nginx that adds RTMP support"
+arch=('i686' 'x86_64')
+depends=('nginx')
+url="https://github.com/kwojtek/nginx-rtmpt-proxy-module.git"
+license=('BSD')
+
+source=(
+ http://nginx.org/download/nginx-$_nginxver.tar.gz
+ http://nginx.org/download/nginx-$_nginxver.tar.gz.asc
+ https://github.com/kwojtek/$_modname/archive/master.zip
+)
+sha256sums=('SKIP'
+ 'SKIP'
+ 'SKIP')
+#validpgpkeys=('B0F4253373F8F6F510D42178520A9993A1C052F8')
+
+build() {
+ cd "$srcdir"/nginx-$_nginxver
+ ./configure --with-compat --add-dynamic-module=../$_modname-master
+ make modules
+}
+
+package() {
+ cd "$srcdir"/nginx-$_nginxver/objs
+ for mod in *.so; do
+ install -Dm755 $mod "$pkgdir"/usr/lib/nginx/modules/$mod
+ done
+}