summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartchus2020-04-24 18:26:31 +0200
committerMartchus2020-04-24 18:26:31 +0200
commit00f5f284c95e7c9c41dcf88458d16c1ca9f385cb (patch)
tree1e9a48a1d8b5322df26d8cb4b892ac5e86d4dbe4
parent78c9cddf16c3c05b4113d8ce8ccd5911ae597935 (diff)
downloadaur-00f5f284c95e7c9c41dcf88458d16c1ca9f385cb.tar.gz
Rebuild against NGINX 1.18.0
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD22
2 files changed, 12 insertions, 20 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1cb752719a76..7ab575195c21 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,19 +1,15 @@
pkgbase = nginx-mod-upload-progress
pkgdesc = NGINX module implementing an upload progress system, that monitors RFC1867 POST uploads
pkgver = 0.9.2
- pkgrel = 5
+ pkgrel = 6
url = https://github.com/masterzen/nginx-upload-progress-module
arch = x86_64
license = CUSTOM
- depends = nginx=1.16.1
+ makedepends = nginx-src
+ depends = nginx=1.18.0
depends = libutil-linux
- source = https://nginx.org/download/nginx-1.16.1.tar.gz
- source = https://nginx.org/download/nginx-1.16.1.tar.gz.asc
source = nginx-mod-upload-progress-0.9.2::https://github.com/masterzen/nginx-upload-progress-module/archive/v0.9.2.tar.gz
source = 0001-Fix-ngx_module_type.patch::https://github.com/masterzen/nginx-upload-progress-module/commit/dd138546b16a01e9c09613d02211373baf1cac02.patch
- validpgpkeys = B0F4253373F8F6F510D42178520A9993A1C052F8
- sha256sums = f11c2a6dd1d3515736f0324857957db2de98be862461b5a542a3ac6188dbe32b
- sha256sums = SKIP
sha256sums = b286689355442657650421d8e8398bd4abf9dbbaade65947bb0cb74a349cc497
sha256sums = 4fdf5269aadce50cc8ab6f2ffed19df40db681b25c6a37fa660686aa07ff3a27
diff --git a/PKGBUILD b/PKGBUILD
index f9903b713694..1477676b7907 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,25 +3,20 @@
pkgname=nginx-mod-upload-progress
pkgver=0.9.2
-pkgrel=5
+pkgrel=6
_dirname="nginx-upload-progress-module-$pkgver"
-_nginxver=1.16.1
+_nginxver=1.18.0
pkgdesc='NGINX module implementing an upload progress system, that monitors RFC1867 POST uploads'
arch=('x86_64')
depends=("nginx=$_nginxver" "libutil-linux")
+makedepends=("nginx-src")
url='https://github.com/masterzen/nginx-upload-progress-module'
license=('CUSTOM')
-source=(
- https://nginx.org/download/nginx-$_nginxver.tar.gz{,.asc}
- "$pkgname-$pkgver::https://github.com/masterzen/nginx-upload-progress-module/archive/v${pkgver}.tar.gz"
- '0001-Fix-ngx_module_type.patch::https://github.com/masterzen/nginx-upload-progress-module/commit/dd138546b16a01e9c09613d02211373baf1cac02.patch'
-)
-validpgpkeys=(B0F4253373F8F6F510D42178520A9993A1C052F8) # Maxim Dounin <mdounin@mdounin.ru>
-sha256sums=('f11c2a6dd1d3515736f0324857957db2de98be862461b5a542a3ac6188dbe32b'
- 'SKIP'
- 'b286689355442657650421d8e8398bd4abf9dbbaade65947bb0cb74a349cc497'
+source=("$pkgname-$pkgver::https://github.com/masterzen/nginx-upload-progress-module/archive/v${pkgver}.tar.gz"
+ '0001-Fix-ngx_module_type.patch::https://github.com/masterzen/nginx-upload-progress-module/commit/dd138546b16a01e9c09613d02211373baf1cac02.patch')
+sha256sums=('b286689355442657650421d8e8398bd4abf9dbbaade65947bb0cb74a349cc497'
'4fdf5269aadce50cc8ab6f2ffed19df40db681b25c6a37fa660686aa07ff3a27')
prepare() {
@@ -30,14 +25,15 @@ prepare() {
}
build() {
- cd "$srcdir"/nginx-$_nginxver
+ cp -r /usr/src/nginx .
+ cd "$srcdir"/nginx
./configure --with-compat --add-dynamic-module="../$_dirname"
make modules
}
package() {
install -Dm755 "$srcdir/$_dirname/LICENSE" "$pkgdir/usr/share/licenses/${pkgname}/LICENSE"
- cd "$srcdir"/nginx-$_nginxver/objs
+ cd "$srcdir"/nginx/objs
for mod in ngx_*.so; do
install -Dm755 $mod "$pkgdir"/usr/lib/nginx/modules/$mod
done