summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartchus2018-04-22 18:30:18 +0200
committerMartchus2018-04-22 18:30:18 +0200
commitaeda1cb67a667ee1063987842ea2786cda11bf49 (patch)
tree74b6e44818de830a7e11beeedf0ff00cfb3df355
downloadaur-aeda1cb67a667ee1063987842ea2786cda11bf49.tar.gz
Initial import
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD44
2 files changed, 65 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..02153b7acdb6
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = nginx-mod-upload-progress
+ pkgdesc = NGINX module implementing an upload progress system, that monitors RFC1867 POST uploads
+ pkgver = 0.9.2
+ pkgrel = 1
+ url = https://github.com/masterzen/nginx-upload-progress-module
+ arch = x86_64
+ license = CUSTOM
+ depends = nginx=1.14.0
+ depends = libutil-linux
+ source = https://nginx.org/download/nginx-1.14.0.tar.gz
+ source = https://nginx.org/download/nginx-1.14.0.tar.gz.asc
+ source = nginx-mod-upload-progress-0.9.2::https://github.com/masterzen/nginx-upload-progress-module/archive/v0.9.2.tar.gz
+ source = 0001-Fix-ngx_module_type.patch::https://github.com/masterzen/nginx-upload-progress-module/commit/dd138546b16a01e9c09613d02211373baf1cac02.patch
+ validpgpkeys = B0F4253373F8F6F510D42178520A9993A1C052F8
+ sha256sums = 5d15becbf69aba1fe33f8d416d97edd95ea8919ea9ac519eff9bafebb6022cb5
+ sha256sums = SKIP
+ sha256sums = b286689355442657650421d8e8398bd4abf9dbbaade65947bb0cb74a349cc497
+ sha256sums = 4fdf5269aadce50cc8ab6f2ffed19df40db681b25c6a37fa660686aa07ff3a27
+
+pkgname = nginx-mod-upload-progress
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..72f437f8dfb0
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,44 @@
+# $Id$
+# Maintainer: Martchus <martchus@gmx.net>
+
+pkgname=nginx-mod-upload-progress
+pkgver=0.9.2
+pkgrel=1
+_dirname="nginx-upload-progress-module-$pkgver"
+_nginxver=1.14.0
+
+pkgdesc='NGINX module implementing an upload progress system, that monitors RFC1867 POST uploads'
+arch=('x86_64')
+depends=("nginx=$_nginxver" "libutil-linux")
+url='https://github.com/masterzen/nginx-upload-progress-module'
+license=('CUSTOM')
+
+source=(
+ https://nginx.org/download/nginx-$_nginxver.tar.gz{,.asc}
+ "$pkgname-$pkgver::https://github.com/masterzen/nginx-upload-progress-module/archive/v${pkgver}.tar.gz"
+ '0001-Fix-ngx_module_type.patch::https://github.com/masterzen/nginx-upload-progress-module/commit/dd138546b16a01e9c09613d02211373baf1cac02.patch'
+)
+validpgpkeys=(B0F4253373F8F6F510D42178520A9993A1C052F8) # Maxim Dounin <mdounin@mdounin.ru>
+sha256sums=('5d15becbf69aba1fe33f8d416d97edd95ea8919ea9ac519eff9bafebb6022cb5'
+ 'SKIP'
+ 'b286689355442657650421d8e8398bd4abf9dbbaade65947bb0cb74a349cc497'
+ '4fdf5269aadce50cc8ab6f2ffed19df40db681b25c6a37fa660686aa07ff3a27')
+
+prepare() {
+ cd "$srcdir/$_dirname"
+ patch -p1 -i '../0001-Fix-ngx_module_type.patch'
+}
+
+build() {
+ cd "$srcdir"/nginx-$_nginxver
+ ./configure --with-compat --add-dynamic-module="../$_dirname"
+ make modules
+}
+
+package() {
+ install -Dm755 "$srcdir/$_dirname/LICENSE" "$pkgdir/usr/share/licenses/${pkgname}/LICENSE"
+ cd "$srcdir"/nginx-$_nginxver/objs
+ for mod in ngx_*.so; do
+ install -Dm755 $mod "$pkgdir"/usr/lib/nginx/modules/$mod
+ done
+}