summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLeo P2015-12-01 14:42:11 -0500
committerLeo P2015-12-01 14:42:11 -0500
commite299e4f9e5f2ee3d262462e3d887cf37394f8151 (patch)
tree416bc380d4f0ed3cb786dcf64712e98cf98bf945
parent62c687af52180967f388a628837587682ff438d0 (diff)
downloadaur-e299e4f9e5f2ee3d262462e3d887cf37394f8151.tar.gz
keep debug symbols around
-rw-r--r--PKGBUILD4
1 files changed, 4 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 8ddf3d9d2c7c..79dc805d69ca 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,6 +2,8 @@
_nginx_ver_latest=1.9.5
_nginx_ver_stable=1.8.0
+OPTIONS=(!strip debug) #nchan is still young, in case something goes wrong we want good coredumps
+
_nginx_ver=$_nginx_ver_stable
_pkgname=nginx
@@ -92,6 +94,8 @@ build() {
--with-http_secure_link_module
--with-debug
--add-module="${srcdir}/nchan")
+
+ CFLAGS="$CFLAGS -ggdb" #make sure debug symbols are present
./configure ${CONFIGURE[@]}
make