summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMasato TOYOSHIMA2023-10-19 18:14:37 +0900
committerMasato TOYOSHIMA2023-10-19 18:14:37 +0900
commit03022a678bb6795baee1a5a29c9a845b85955c78 (patch)
tree5e6b0c47c2b4f0770888e227bd1183b656d3f070
parent9cc2fb6618e4eed99d18110d6fd130cfc446dbce (diff)
downloadaur-03022a678bb6795baee1a5a29c9a845b85955c78.tar.gz
update
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD10
2 files changed, 12 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index eff826cd9e81..eb23f2d9557b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = nginx-quic
pkgdesc = Lightweight HTTP server and IMAP/POP3 proxy server, HTTP/3 QUIC branch
pkgver = 1.25.2
- pkgrel = 3
+ pkgrel = 4
url = https://nginx.org
install = nginx.install
arch = i686
@@ -28,7 +28,7 @@ pkgbase = nginx-quic
backup = etc/nginx/uwsgi_params
backup = etc/nginx/win-utf
backup = etc/logrotate.d/nginx
- source = hg+https://hg.nginx.org/nginx-quic#revision=cdda286c0f1b
+ source = hg+https://hg.nginx.org/nginx-quic#revision=3038bd4d7816
source = https://cdn.openbsd.org/pub/OpenBSD/LibreSSL/libressl-3.7.3.tar.gz
source = service
source = logrotate
@@ -42,7 +42,9 @@ pkgname = nginx-quic
pkgname = nginx-quic-src
pkgdesc = Source code of nginx-quic 1.25.2, useful for building modules
arch = any
- depends =
+ depends = sh
+ depends = bash
+ depends = perl
provides = nginx-src
provides = nginx-mainline-src
conflicts = nginx-src
diff --git a/PKGBUILD b/PKGBUILD
index 767904f78bde..a6a52072e361 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,11 +5,11 @@
# Contributor: Drew DeVault
_pkgbase=nginx
-_commit=cdda286c0f1b
+_commit=3038bd4d7816
pkgbase=nginx-quic
pkgname=(nginx-quic nginx-quic-src)
pkgver=1.25.2
-pkgrel=3
+pkgrel=4
pkgdesc='Lightweight HTTP server and IMAP/POP3 proxy server, HTTP/3 QUIC branch'
arch=('i686' 'x86_64')
url='https://nginx.org'
@@ -178,7 +178,7 @@ package_nginx-quic-src() {
arch=('any')
provides=('nginx-src' 'nginx-mainline-src')
conflicts=($_pkgbase-src)
- depends=()
+ depends=("sh" "bash" "perl")
backup=()
install -d "$pkgdir/usr/src"
test -d "$pkgdir/usr/src/nginx" && rm -r "$pkgdir/usr/src/nginx"
@@ -188,6 +188,10 @@ package_nginx-quic-src() {
# Link the 'configure' script to its location in release tarballs,
# as this is where modules expect it
ln -s /usr/src/nginx/auto/configure "$pkgdir/usr/src/nginx"
+ cd $pkgname
+ install -Dm644 docs/text/LICENSE "$pkgdir"/usr/share/licenses/$provides/LICENSE
+ install -d "$pkgdir"/usr/share/licenses/$pkgname
+ ln -s /usr/share/licenses/$provides/LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
}
# vim:set ts=2 sw=2 et: