summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDasSkelett2021-04-23 15:55:38 +0200
committerDasSkelett2021-04-23 15:55:38 +0200
commit2243a2685705f188ac38f8fbdbdf2d5dacc222c2 (patch)
treec94be9d093131cc9ecbb4d75dd3a4c6523f2c947
parent13d89f73641365c70358f39ad4fb39838829faf9 (diff)
downloadaur-2243a2685705f188ac38f8fbdbdf2d5dacc222c2.tar.gz
Update to nginx 1.20.0
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD16
2 files changed, 16 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index edee746ed0aa..60ce8871fc98 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = nginx-quic
pkgdesc = Lightweight HTTP server and IMAP/POP3 proxy server, HTTP/3 QUIC branch
- pkgver = 1.19.10
- pkgrel = 2
+ pkgver = 1.20.0
+ pkgrel = 1
url = https://nginx.org
install = nginx.install
arch = i686
@@ -27,8 +27,8 @@ pkgbase = nginx-quic
backup = etc/nginx/uwsgi_params
backup = etc/nginx/win-utf
backup = etc/logrotate.d/nginx
- source = hg+https://hg.nginx.org/nginx-quic#revision=47a43b011dec
- source = git+https://boringssl.googlesource.com/boringssl#commit=0da75f35d51ab7fbfa8efaf71c87606ee26f5db3
+ source = hg+https://hg.nginx.org/nginx-quic#revision=225e9f1dfe7c
+ source = git+https://boringssl.googlesource.com/boringssl#commit=68a799af7f6aed15dfeedc26e5ae43ebce873a6a
source = service
source = logrotate
sha256sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 6c419958be97..782b639f0772 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,8 +5,8 @@
# Contributor: Drew DeVault
pkgname=nginx-quic
-pkgver=1.19.10
-pkgrel=2
+pkgver=1.20.0
+pkgrel=1
pkgdesc='Lightweight HTTP server and IMAP/POP3 proxy server, HTTP/3 QUIC branch'
arch=('i686' 'x86_64')
url='https://nginx.org'
@@ -25,8 +25,8 @@ backup=('etc/nginx/fastcgi.conf'
install=nginx.install
provides=('nginx')
conflicts=('nginx')
-source=("hg+https://hg.nginx.org/nginx-quic#revision=47a43b011dec"
- "git+https://boringssl.googlesource.com/boringssl#commit=0da75f35d51ab7fbfa8efaf71c87606ee26f5db3"
+source=("hg+https://hg.nginx.org/nginx-quic#revision=225e9f1dfe7c"
+ "git+https://boringssl.googlesource.com/boringssl#commit=68a799af7f6aed15dfeedc26e5ae43ebce873a6a"
"service"
"logrotate")
sha256sums=('SKIP'
@@ -72,6 +72,14 @@ _quic_flags=(
--with-stream_quic_module
)
+prepare() {
+ # Upstream hasn't merged the 1.20.0 update into the nginx-quic branch yet; do it manually
+ cd ${srcdir}/$pkgname
+ hg pull https://hg.nginx.org/nginx
+ hg merge 3ebf8a5fb670
+ hg commit -u aur -m "[automated aur commit] Merged with default branch"
+}
+
build() {
export CPPFLAGS=${CPPFLAGS/-D_FORTIFY_SOURCE=[1-9]/-D_FORTIFY_SOURCE=0}
export CXXFLAGS="$CXXFLAGS -fPIC"