summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDasSkelett2021-07-16 12:29:23 +0200
committerDasSkelett2021-07-16 12:29:23 +0200
commit3bd21bfd1f09fe37fa64ef4ccf1426e4adfe374f (patch)
tree10d02e093c7b74f83a158758e36318cbcc32d93f
parentcfcd3a581ec4a9c1f39f7b2b6ef7ef3b096e5139 (diff)
downloadaur-3bd21bfd1f09fe37fa64ef4ccf1426e4adfe374f.tar.gz
Update to nginx 1.21.1
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD9
2 files changed, 9 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index cebd074c4a6a..ea51828b6a9b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = nginx-quic
pkgdesc = Lightweight HTTP server and IMAP/POP3 proxy server, HTTP/3 QUIC branch
- pkgver = 1.21.0
- pkgrel = 3
+ pkgver = 1.21.1
+ pkgrel = 1
url = https://nginx.org
install = nginx.install
arch = i686
@@ -27,8 +27,8 @@ pkgbase = nginx-quic
backup = etc/nginx/uwsgi_params
backup = etc/nginx/win-utf
backup = etc/logrotate.d/nginx
- source = hg+https://hg.nginx.org/nginx-quic#revision=1fec68e322d0
- source = git+https://boringssl.googlesource.com/boringssl#commit=c3b373bf4f4b2e2fba2578d1d5b5fe04e410f7cb
+ source = hg+https://hg.nginx.org/nginx-quic#revision=6674a50cbb6c
+ source = git+https://boringssl.googlesource.com/boringssl#commit=62d6ed60dc192433d05fcc786a8dc0df23e80c96
source = service
source = logrotate
sha256sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index f768ddac150c..687608b87e11 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,8 +5,8 @@
# Contributor: Drew DeVault
pkgname=nginx-quic
-pkgver=1.21.0
-pkgrel=3
+pkgver=1.21.1
+pkgrel=1
pkgdesc='Lightweight HTTP server and IMAP/POP3 proxy server, HTTP/3 QUIC branch'
arch=('i686' 'x86_64')
url='https://nginx.org'
@@ -25,8 +25,8 @@ backup=('etc/nginx/fastcgi.conf'
install=nginx.install
provides=('nginx')
conflicts=('nginx')
-source=("hg+https://hg.nginx.org/nginx-quic#revision=1fec68e322d0"
- "git+https://boringssl.googlesource.com/boringssl#commit=c3b373bf4f4b2e2fba2578d1d5b5fe04e410f7cb"
+source=("hg+https://hg.nginx.org/nginx-quic#revision=6674a50cbb6c"
+ "git+https://boringssl.googlesource.com/boringssl#commit=62d6ed60dc192433d05fcc786a8dc0df23e80c96"
"service"
"logrotate")
sha256sums=('SKIP'
@@ -78,6 +78,7 @@ build() {
export CXXFLAGS=${CXXFLAGS/-D_FORTIFY_SOURCE=[1-9]/-D_FORTIFY_SOURCE=0}
export CXXFLAGS="$CXXFLAGS -fPIC"
+ # Disable some warnings that make Boringssl fail to compile due to a forced -Werror in CMakeLists.txt
export CFLAGS="$CFLAGS -fPIC -Wno-stringop-overflow -Wno-array-parameter"
cd ${srcdir}/boringssl