summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDasSkelett2021-04-15 17:25:38 +0200
committerDasSkelett2021-04-15 17:25:38 +0200
commit551e3ed67d92e2d10c8b321439ecc3d82f4b5d0e (patch)
tree905f2232da3ad6eeaf79f035e1e69818a70f95af
parentd0b7e3d9f26bd221b42235e496f3c80f19485917 (diff)
downloadaur-551e3ed67d92e2d10c8b321439ecc3d82f4b5d0e.tar.gz
Update to nginx 1.19.10
Upstream hasn't merged the default branch updates for 1.19.10 into the nginx-quic branch yet, so we need to do it manually before the build.
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD12
2 files changed, 12 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ba89a402d8da..6a53c46da6b3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = nginx-quic
pkgdesc = Lightweight HTTP server and IMAP/POP3 proxy server, HTTP/3 QUIC branch
- pkgver = 1.19.9
+ pkgver = 1.19.10
pkgrel = 1
url = https://nginx.org
install = nginx.install
@@ -27,7 +27,7 @@ pkgbase = nginx-quic
backup = etc/nginx/uwsgi_params
backup = etc/nginx/win-utf
backup = etc/logrotate.d/nginx
- source = hg+https://hg.nginx.org/nginx-quic#revision=f1986657fc26
+ source = hg+https://hg.nginx.org/nginx-quic#revision=cc3e9c131d79
source = git+https://boringssl.googlesource.com/boringssl#commit=0da75f35d51ab7fbfa8efaf71c87606ee26f5db3
source = service
source = logrotate
diff --git a/PKGBUILD b/PKGBUILD
index 62ee4c21b41e..81c4ad137cde 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@
# Contributor: Drew DeVault
pkgname=nginx-quic
-pkgver=1.19.9
+pkgver=1.19.10
pkgrel=1
pkgdesc='Lightweight HTTP server and IMAP/POP3 proxy server, HTTP/3 QUIC branch'
arch=('i686' 'x86_64')
@@ -25,7 +25,7 @@ backup=('etc/nginx/fastcgi.conf'
install=nginx.install
provides=('nginx')
conflicts=('nginx')
-source=("hg+https://hg.nginx.org/nginx-quic#revision=f1986657fc26"
+source=("hg+https://hg.nginx.org/nginx-quic#revision=cc3e9c131d79"
"git+https://boringssl.googlesource.com/boringssl#commit=0da75f35d51ab7fbfa8efaf71c87606ee26f5db3"
"service"
"logrotate")
@@ -72,6 +72,14 @@ _quic_flags=(
--with-stream_quic_module
)
+prepare() {
+ # Upstream hasn't merged the 1.19.10 update into the nginx-quic branch yet; do it manually
+ cd ${srcdir}/$pkgname
+ hg pull https://hg.nginx.org/nginx
+ hg merge b56c45e3bd50
+ hg commit -u aur -m "[automated aur commit] Merged with default branch"
+}
+
build() {
export CPPFLAGS=${CPPFLAGS/-D_FORTIFY_SOURCE=[1-9]/-D_FORTIFY_SOURCE=0}
export CXXFLAGS="$CXXFLAGS -fPIC"