summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDasSkelett2022-05-29 11:58:58 +0200
committerDasSkelett2022-05-29 11:58:58 +0200
commit619a86a80c31a5e412055fdbc38dd740e6bd1df3 (patch)
tree9e116b1cb2c06b507502a347c55b092f15126ecb
parent809d821dfadb4bba6d100ace8f815851f6580963 (diff)
downloadaur-619a86a80c31a5e412055fdbc38dd740e6bd1df3.tar.gz
Update to nginx 1.22.0
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD14
2 files changed, 15 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 71af3c1b5b7a..5468218b3d44 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = nginx-quic
pkgdesc = Lightweight HTTP server and IMAP/POP3 proxy server, HTTP/3 QUIC branch
- pkgver = 1.21.6
- pkgrel = 3
+ pkgver = 1.22.0
+ pkgrel = 1
url = https://nginx.org
install = nginx.install
arch = i686
@@ -28,8 +28,8 @@ pkgbase = nginx-quic
backup = etc/nginx/uwsgi_params
backup = etc/nginx/win-utf
backup = etc/logrotate.d/nginx
- source = hg+https://hg.nginx.org/nginx-quic#revision=7c2adf237091
- source = git+https://boringssl.googlesource.com/boringssl#commit=b90261a383352056a6a01296238499c063d265f0
+ source = hg+https://hg.nginx.org/nginx-quic#revision=5b1011b5702b
+ source = git+https://boringssl.googlesource.com/boringssl#commit=701d8b28c8e49bdc2f90407864ba4f634cf345dd
source = service
source = logrotate
sha256sums = SKIP
@@ -40,7 +40,7 @@ pkgbase = nginx-quic
pkgname = nginx-quic
pkgname = nginx-quic-src
- pkgdesc = Source code of nginx-quic 1.21.6, useful for building modules
+ pkgdesc = Source code of nginx-quic 1.22.0, useful for building modules
arch = any
depends =
provides = nginx-src
diff --git a/PKGBUILD b/PKGBUILD
index bef17682f1cb..1cd6bcfb7956 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,8 +7,8 @@
_pkgbase=nginx
pkgbase=nginx-quic
pkgname=(nginx-quic nginx-quic-src)
-pkgver=1.21.6
-pkgrel=3
+pkgver=1.22.0
+pkgrel=1
pkgdesc='Lightweight HTTP server and IMAP/POP3 proxy server, HTTP/3 QUIC branch'
arch=('i686' 'x86_64')
url='https://nginx.org'
@@ -27,8 +27,8 @@ backup=('etc/nginx/fastcgi.conf'
install=nginx.install
provides=('nginx' 'nginx-mainline')
conflicts=('nginx')
-source=("hg+https://hg.nginx.org/nginx-quic#revision=7c2adf237091"
- "git+https://boringssl.googlesource.com/boringssl#commit=b90261a383352056a6a01296238499c063d265f0"
+source=("hg+https://hg.nginx.org/nginx-quic#revision=5b1011b5702b"
+ "git+https://boringssl.googlesource.com/boringssl#commit=701d8b28c8e49bdc2f90407864ba4f634cf345dd"
"service"
"logrotate")
sha256sums=('SKIP'
@@ -76,6 +76,12 @@ _quic_flags=(
)
prepare() {
+ # Upstream hasn't merged the 1.20.0 update into the nginx-quic branch yet; do it manually
+ cd ${srcdir}/${pkgname}
+ hg pull https://hg.nginx.org/nginx
+ hg merge 2d3ed138ce65 || hg resolve -t internal:other --all
+ hg commit -u aur -m "[automated aur commit] Merged with default branch"
+
# Backup pristine version of nginx source for -src package
test -d ${srcdir}/${pkgname}-src && rm -r ${srcdir}/${pkgname}-src
cp -r ${srcdir}/${pkgname} ${srcdir}/${pkgname}-src