summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDasSkelett2021-05-26 13:47:01 +0200
committerDasSkelett2021-05-26 13:47:01 +0200
commit6cb3a7c0c68fb2ce5c0b7cec81988569c46d8ca4 (patch)
tree2d8e95752b768b627f5cd8c8406c0c4193c34b65
parent6dbf39804b0ef2ea8fae86ba00e7ca132869bc13 (diff)
downloadaur-6cb3a7c0c68fb2ce5c0b7cec81988569c46d8ca4.tar.gz
Fix build with GCC 11
-rw-r--r--.SRCINFO2
-rw-r--r--.gitignore7
-rw-r--r--PKGBUILD4
3 files changed, 8 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8fc0d4a74b43..a69c67972f4b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = nginx-quic
pkgdesc = Lightweight HTTP server and IMAP/POP3 proxy server, HTTP/3 QUIC branch
pkgver = 1.21.0
- pkgrel = 1
+ pkgrel = 2
url = https://nginx.org
install = nginx.install
arch = i686
diff --git a/.gitignore b/.gitignore
index b48ffa8810f9..7da98609d56f 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,8 +1,11 @@
pkg/
src/
+nginx-*/
+boringssl/
*.pkg*
*.tar*
-nginx-*/
-boringssl/
+testing/
+
+.dockerignore
diff --git a/PKGBUILD b/PKGBUILD
index 94f1c35d6000..8824e1087b25 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,7 +6,7 @@
pkgname=nginx-quic
pkgver=1.21.0
-pkgrel=1
+pkgrel=2
pkgdesc='Lightweight HTTP server and IMAP/POP3 proxy server, HTTP/3 QUIC branch'
arch=('i686' 'x86_64')
url='https://nginx.org'
@@ -86,7 +86,7 @@ build() {
export CXXFLAGS=${CXXFLAGS/-D_FORTIFY_SOURCE=[1-9]/-D_FORTIFY_SOURCE=0}
export CXXFLAGS="$CXXFLAGS -fPIC"
- export CFLAGS="$CFLAGS -fPIC"
+ export CFLAGS="$CFLAGS -fPIC -Wno-stringop-overflow -Wno-array-parameter"
cd ${srcdir}/boringssl
mkdir build && cd build && cmake -DCMAKE_BUILD_TYPE=Release ../ && make