summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDasSkelett2022-05-21 15:30:11 +0200
committerDasSkelett2022-05-21 15:30:11 +0200
commit809d821dfadb4bba6d100ace8f815851f6580963 (patch)
tree185e030f699579494f139e6fc077454977b69437
parentb37728f1befed3d9192a43f212c17707615b1fd0 (diff)
downloadaur-809d821dfadb4bba6d100ace8f815851f6580963.tar.gz
Add -Wno-array-bounds CFLAG to unbreak build with GCC 12.1
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD5
2 files changed, 4 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0da1639f17f9..71af3c1b5b7a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = nginx-quic
pkgdesc = Lightweight HTTP server and IMAP/POP3 proxy server, HTTP/3 QUIC branch
pkgver = 1.21.6
- pkgrel = 2
+ pkgrel = 3
url = https://nginx.org
install = nginx.install
arch = i686
diff --git a/PKGBUILD b/PKGBUILD
index 69fcf0abf917..bef17682f1cb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,7 +8,7 @@ _pkgbase=nginx
pkgbase=nginx-quic
pkgname=(nginx-quic nginx-quic-src)
pkgver=1.21.6
-pkgrel=2
+pkgrel=3
pkgdesc='Lightweight HTTP server and IMAP/POP3 proxy server, HTTP/3 QUIC branch'
arch=('i686' 'x86_64')
url='https://nginx.org'
@@ -88,7 +88,8 @@ build() {
export CXXFLAGS="$CXXFLAGS -fPIC"
# Disable some warnings that make Boringssl fail to compile due to a forced -Werror in CMakeLists.txt
- export CFLAGS="$CFLAGS -fPIC -Wno-stringop-overflow -Wno-array-parameter"
+ # -Wno-array-bounds: 2022-05-21 for compatiblity with GCC 12.1 (https://bugs.chromium.org/p/boringssl/issues/detail?id=492&sort=-modified)
+ export CFLAGS="$CFLAGS -fPIC -Wno-stringop-overflow -Wno-array-parameter -Wno-array-bounds"
cd ${srcdir}/boringssl
mkdir build && cd build && cmake -DCMAKE_BUILD_TYPE=Release ../ && make crypto ssl