summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDasSkelett2021-09-13 01:04:23 +0200
committerDasSkelett2021-09-13 01:04:23 +0200
commite28c03f58b086bb7788e861e20b4d64bc216460d (patch)
tree3b5c888860643f9e343a09d1fba1b870e58011a7
parent17208eb32aa0f0976f79d0ed711a865a1c1d5b45 (diff)
downloadaur-e28c03f58b086bb7788e861e20b4d64bc216460d.tar.gz
Only compile necessary boringssl modules, skip tests
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD7
2 files changed, 7 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 648c0e745865..0459212b4c87 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = nginx-quic
pkgdesc = Lightweight HTTP server and IMAP/POP3 proxy server, HTTP/3 QUIC branch
pkgver = 1.21.3
- pkgrel = 1
+ pkgrel = 2
url = https://nginx.org
install = nginx.install
arch = i686
@@ -41,6 +41,7 @@ pkgname = nginx-quic
pkgname = nginx-quic-src
pkgdesc = Source code of nginx-quic 1.21.3, useful for building modules
+ arch = any
depends =
provides = nginx-src
provides = nginx-mainline-src
diff --git a/PKGBUILD b/PKGBUILD
index fbd13edd6e74..29b0f7e85eb4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,7 +8,7 @@ _pkgbase=nginx
pkgbase=nginx-quic
pkgname=(nginx-quic nginx-quic-src)
pkgver=1.21.3
-pkgrel=1
+pkgrel=2
pkgdesc='Lightweight HTTP server and IMAP/POP3 proxy server, HTTP/3 QUIC branch'
arch=('i686' 'x86_64')
url='https://nginx.org'
@@ -78,6 +78,7 @@ _quic_flags=(
prepare() {
# Backup pristine version of nginx source for -src package
+ test -d ${srcdir}/${pkgname}-src && rm -r ${srcdir}/${pkgname}-src
cp -r ${srcdir}/${pkgname} ${srcdir}/${pkgname}-src
}
@@ -91,7 +92,7 @@ build() {
export CFLAGS="$CFLAGS -fPIC -Wno-stringop-overflow -Wno-array-parameter"
cd ${srcdir}/boringssl
- mkdir build && cd build && cmake -DCMAKE_BUILD_TYPE=Release ../ && make
+ mkdir build && cd build && cmake -DCMAKE_BUILD_TYPE=Release ../ && make crypto ssl
cd ${srcdir}/boringssl
mkdir -p .openssl/lib && cd .openssl && ln -s ../include . && cd ../
cp ${srcdir}/boringssl/build/crypto/libcrypto.a ${srcdir}/boringssl/build/ssl/libssl.a .openssl/lib && cd ..
@@ -163,11 +164,13 @@ package_nginx-quic() {
package_nginx-quic-src() {
pkgdesc="Source code of nginx-quic $pkgver, useful for building modules"
+ arch=('any')
provides=('nginx-src' 'nginx-mainline-src')
conflicts=($_pkgbase-src)
depends=()
backup=()
install -d "$pkgdir/usr/src"
+ test -d "$pkgdir/usr/src/nginx" && rm -r "$pkgdir/usr/src/nginx"
cp -r ${srcdir}/${pkgname} "$pkgdir/usr/src/nginx"
# Link the 'configure' script to its location in release tarballs,
# as this is where modules expect it