summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMasato TOYOSHIMA2024-03-26 10:26:58 +0900
committerMasato TOYOSHIMA2024-03-26 10:26:58 +0900
commitb6a9c1dbfb380ef88f61f1001af67f526aba1d84 (patch)
treed355f3413b7292702d189bc95b1fd63affdc3744
parent78a62c5d687f6dafd543fdc2f7d8bd30f2ab7f13 (diff)
downloadaur-b6a9c1dbfb380ef88f61f1001af67f526aba1d84.tar.gz
update
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD7
2 files changed, 7 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1252016d4bc0..68c6f7916423 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -6,7 +6,7 @@ pkgbase = nginx-quic-libressl
install = nginx.install
arch = i686
arch = x86_64
- license = custom
+ license = BSD-2-Clause-Views AND OpenSSL
makedepends = cmake
makedepends = git
makedepends = go
@@ -28,7 +28,7 @@ pkgbase = nginx-quic-libressl
backup = etc/nginx/uwsgi_params
backup = etc/nginx/win-utf
backup = etc/logrotate.d/nginx
- source = hg+https://hg.nginx.org/nginx#revision=ee40e2b1d083
+ source = hg+https://hg.nginx.org/nginx#revision=6317e21a15e0
source = https://cdn.openbsd.org/pub/OpenBSD/LibreSSL/libressl-3.8.2.tar.gz
source = service
source = logrotate
diff --git a/PKGBUILD b/PKGBUILD
index 58ea700c50cd..95063b7575b2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,7 +6,7 @@
# Contributor: Drew DeVault
_pkgbase=nginx
-_commit=ee40e2b1d083
+_commit=6317e21a15e0
pkgbase=nginx-quic-libressl
pkgname=(nginx-quic-libressl nginx-quic-libressl-src)
pkgver=1.25.3
@@ -14,7 +14,7 @@ pkgrel=5
pkgdesc='Lightweight HTTP server and IMAP/POP3 proxy server, HTTP/3 QUIC branch'
arch=('i686' 'x86_64')
url='https://nginx.org'
-license=('custom')
+license=('BSD-2-Clause-Views AND OpenSSL')
depends=('geoip' 'libxcrypt' 'pcre2' 'zlib' 'glibc')
makedepends=('cmake' 'git' 'go' 'mercurial')
backup=('etc/nginx/fastcgi.conf'
@@ -173,6 +173,8 @@ package_nginx-quic-libressl() {
install -Dm644 contrib/vim/${i}/nginx.vim \
"${pkgdir}/usr/share/vim/vimfiles/${i}/nginx.vim"
done
+ install -Dm644 "$srcdir"/libressl-3.8.2/COPYING "$pkgdir"/usr/share/licenses/$pkgname/LICENSE-LIBRESSL
+
}
package_nginx-quic-libressl-src() {
@@ -194,6 +196,7 @@ package_nginx-quic-libressl-src() {
install -Dm644 docs/text/LICENSE "$pkgdir"/usr/share/licenses/$provides/LICENSE
install -d "$pkgdir"/usr/share/licenses/$pkgname
ln -s /usr/share/licenses/$provides/LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
+ install -Dm644 "$srcdir"/libressl-3.8.2/COPYING "$pkgdir"/usr/share/licenses/$pkgname/LICENSE-LIBRESSL
}
# vim:set ts=2 sw=2 et: