summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKasei Wang2021-03-23 19:28:19 +0800
committerKasei Wang2021-03-23 19:28:19 +0800
commit6c42b71effb63fb9e04a405b047456ef63d47cd6 (patch)
treebc5ef71f4b45329d4917236a8126a7eb73a4248c
parentdfc1ce3cb170c1bbe7b6c90941ff62d7473e732b (diff)
downloadaur-6c42b71effb63fb9e04a405b047456ef63d47cd6.tar.gz
addpkg: nginx-quiche 1.16.1-1
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD31
2 files changed, 19 insertions, 23 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3d105b63b514..aea280b1900d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,5 +1,5 @@
-pkgbase = nginx
- pkgdesc = Lightweight HTTP server and IMAP/POP3 proxy server
+pkgbase = nginx-quiche
+ pkgdesc = Lightweight HTTP server and IMAP/POP3 proxy server with cloudflare quiche for http3
pkgver = 1.16.1
pkgrel = 1
url = https://nginx.org
@@ -48,8 +48,7 @@ pkgbase = nginx
md5sums = ba2e3b08ce0f0fff7cced624d0ecf7cc
md5sums = 6a01fb17af86f03707c8ae60f98a2dc2
-pkgname = nginx
-
-pkgname = nginx-src
- depends =
+pkgname = nginx-quiche
+ provides = nginx
+ conflicts = nginx
diff --git a/PKGBUILD b/PKGBUILD
index a616917e8b59..c0203cb2422b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,12 +4,13 @@
# Contributor: Miroslaw Szot <mss@czlug.icis.pcz.pl>
# Contributor: Daniel Micay <danielmicay@gmail.com>
-pkgbase=nginx
-pkgname=(nginx nginx-src)
+_pkgbase=nginx
+pkgbase=${_pkgbase}-quiche
+pkgname=${pkgbase}
pkgver=1.16.1
pkgrel=1
_quichever=0.7.0
-pkgdesc='Lightweight HTTP server and IMAP/POP3 proxy server'
+pkgdesc='Lightweight HTTP server and IMAP/POP3 proxy server with cloudflare quiche for http3'
arch=(x86_64)
url='https://nginx.org'
license=(custom)
@@ -77,19 +78,13 @@ _stable_flags=(
)
prepare() {
- cp -r $pkgbase-$pkgver{,-src}
-
- #cd $srcdir/boringssl
- #mkdir build && cd build && cmake ../ && make && cd $srcdir/boringssl
- #mkdir -p .openssl/lib && cd .openssl && ln -s ../include . && cd ../
- #cp $srcdir/boringssl/build/crypto/libcrypto.a $srcdir/boringssl/build/ssl/libssl.a .openssl/lib
- #touch $srcdir/boringssl/.openssl/include/openssl/ssl.h
+ cp -r $_pkgbase-$pkgver{,-src}
cd $srcdir/quiche-$_quichever/deps
rm -r boringssl
ln -s $srcdir/boringssl boringssl
- cd $srcdir/$pkgbase-$pkgver
+ cd $srcdir/$_pkgbase-$pkgver
patch -Np1 -i $srcdir/quiche-$_quichever/extras/nginx/nginx-1.16.patch
}
@@ -97,7 +92,7 @@ build() {
cd $srcdir/boringssl
mkdir build && cd build && cmake ../ && make && cd $srcdir/boringssl
- cd $srcdir/$pkgbase-$pkgver
+ cd $srcdir/$_pkgbase-$pkgver
./configure \
--prefix=/etc/nginx \
@@ -128,11 +123,13 @@ build() {
check() {
cd nginx-tests
- TEST_NGINX_BINARY="$srcdir/$pkgbase-$pkgver/objs/nginx" prove .
+ TEST_NGINX_BINARY="$srcdir/$_pkgbase-$pkgver/objs/nginx" prove .
}
-package_nginx() {
- cd $pkgbase-$pkgver
+package_nginx-quiche() {
+ provides=($_pkgbase)
+ conflicts=($_pkgbase)
+ cd $_pkgbase-$pkgver
make DESTDIR="$pkgdir" install
sed -e 's|\<user\s\+\w\+;|user html;|g' \
@@ -167,8 +164,8 @@ package_nginx() {
done
}
-package_nginx-src() {
+package_nginx-quiche-src() {
depends=()
install -d "$pkgdir/usr/src"
- cp -r $pkgbase-$pkgver-src "$pkgdir/usr/src/nginx"
+ cp -r $_pkgbase-$pkgver-src "$pkgdir/usr/src/nginx-quiche"
}