summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGoliathLabs2020-05-06 12:45:30 +0200
committerGoliathLabs2020-05-06 12:45:30 +0200
commitaf3fdad97bdf6afec4c5547746c8aae0d2736029 (patch)
treee30230c7b5c37cf7a35e2caf36e66298f76fe173
parent84e21dfba4c03938748d68da225b6ae44a09c196 (diff)
downloadaur-af3fdad97bdf6afec4c5547746c8aae0d2736029.tar.gz
Updated: 1.18.0
-rw-r--r--.SRCINFO34
-rw-r--r--PKGBUILD54
-rw-r--r--service1
3 files changed, 67 insertions, 22 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 29177d66ab15..986aebe732f0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,11 +1,20 @@
pkgbase = nginx-rtmp
- pkgdesc = NGINX-based Media Streaming Server
- pkgver = 1.12.2
- pkgrel = 3
+ pkgdesc = Lightweight HTTP server and IMAP/POP3 proxy server
+ pkgver = 1.18.0
+ pkgrel = 1
url = https://nginx-rtmp.blogspot.com/
install = nginx.install
arch = x86_64
license = custom
+ checkdepends = perl
+ checkdepends = perl-gd
+ checkdepends = perl-io-socket-ssl
+ checkdepends = perl-fcgi
+ checkdepends = perl-cache-memcached
+ checkdepends = memcached
+ checkdepends = ffmpeg
+ checkdepends = inetutils
+ makedepends = mercurial
depends = pcre
depends = zlib
depends = openssl
@@ -22,14 +31,23 @@ pkgbase = nginx-rtmp
backup = etc/nginx/uwsgi_params
backup = etc/nginx/win-utf
backup = etc/logrotate.d/nginx
- source = https://nginx.org/download/nginx-1.12.2.tar.gz
+ source = https://nginx.org/download/nginx-1.18.0.tar.gz
+ source = https://nginx.org/download/nginx-1.18.0.tar.gz.asc
+ source = hg+http://hg.nginx.org/nginx-tests#revision=c1d167a13c24
source = https://github.com/arut/nginx-rtmp-module/archive/v1.2.1.tar.gz
source = service
source = logrotate
- md5sums = 4d2fc76211435f029271f1cf6d7eeae3
- md5sums = 639ac2b78103adaccbcfe484a92acf44
- md5sums = ef491e760e7c1ffec9ca25441a150c83
- md5sums = 6a01fb17af86f03707c8ae60f98a2dc2
+ validpgpkeys = B0F4253373F8F6F510D42178520A9993A1C052F8
+ sha256sums = 4c373e7ab5bf91d34a4f11a0c9496561061ba5eee6020db272a17a7228d35f99
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = 87aa597400b0b5a05274ee2d23d8cb8224e12686227a0abe31d783b3a645ea37
+ sha256sums = 113bb2c530afd7f81ebccb42e6fa293fd87be2d87c99a32623097c6b97157297
+ sha256sums = 06ebe161af3e761f2e2e35a67c6c0af27bf61aea7cd4ba8b28372ced5e3b3175
pkgname = nginx-rtmp
+pkgname = nginx-rtmp-src
+ pkgdesc = Source code of nginx 1.18.0, useful for building modules
+ depends =
+
diff --git a/PKGBUILD b/PKGBUILD
index e74834d74eb6..918f7577a8c4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,15 +1,21 @@
-# Maintainer: Hui Yiqun <huiyiqun@gmail.com>
+# Maintainer: Felix Golatofski <contact@xdfr.de>
+# Contributor: Hui Yiqun <huiyiqun@gmail.com>
-_pkgname=nginx
-pkgname=$_pkgname-rtmp
-pkgver=1.12.2
+pkgbase=nginx-rtmp
+_pkgbase=nginx
+pkgname=(nginx-rtmp nginx-rtmp-src)
+pkgver=1.18.0
_rtmpver=1.2.1
-pkgrel=3
-pkgdesc='NGINX-based Media Streaming Server'
+pkgrel=1
+pkgdesc='Lightweight HTTP server and IMAP/POP3 proxy server'
arch=(x86_64)
url='https://nginx-rtmp.blogspot.com/'
+_url='https://nginx.org'
license=(custom)
depends=(pcre zlib openssl geoip mailcap)
+makedepends=(mercurial)
+checkdepends=(perl perl-gd perl-io-socket-ssl perl-fcgi perl-cache-memcached
+ memcached ffmpeg inetutils)
backup=(etc/nginx/fastcgi.conf
etc/nginx/fastcgi_params
etc/nginx/koi-win
@@ -20,19 +26,24 @@ backup=(etc/nginx/fastcgi.conf
etc/nginx/win-utf
etc/logrotate.d/nginx)
install=nginx.install
-source=(https://nginx.org/download/nginx-$pkgver.tar.gz
+source=($_url/download/nginx-$pkgver.tar.gz{,.asc}
+ hg+http://hg.nginx.org/nginx-tests#revision=c1d167a13c24
https://github.com/arut/nginx-rtmp-module/archive/v$_rtmpver.tar.gz
service
logrotate)
+validpgpkeys=(B0F4253373F8F6F510D42178520A9993A1C052F8) # Maxim Dounin <mdounin@mdounin.ru>
provides=('nginx')
conflicts=('nginx')
-md5sums=('4d2fc76211435f029271f1cf6d7eeae3'
- '639ac2b78103adaccbcfe484a92acf44'
- 'ef491e760e7c1ffec9ca25441a150c83'
- '6a01fb17af86f03707c8ae60f98a2dc2')
+sha256sums=('4c373e7ab5bf91d34a4f11a0c9496561061ba5eee6020db272a17a7228d35f99'
+ 'SKIP'
+ 'SKIP'
+ '87aa597400b0b5a05274ee2d23d8cb8224e12686227a0abe31d783b3a645ea37'
+ '113bb2c530afd7f81ebccb42e6fa293fd87be2d87c99a32623097c6b97157297'
+ '06ebe161af3e761f2e2e35a67c6c0af27bf61aea7cd4ba8b28372ced5e3b3175')
_common_flags=(
--with-compat
+ --with-debug
--with-file-aio
--with-http_addition_module
--with-http_auth_request_module
@@ -64,6 +75,10 @@ _common_flags=(
_stable_flags=(
)
+prepare() {
+ cp -r $_pkgbase-$pkgver{,-src}
+}
+
build() {
cd $_pkgname-$pkgver
@@ -82,14 +97,20 @@ build() {
--http-fastcgi-temp-path=/var/lib/nginx/fastcgi \
--http-scgi-temp-path=/var/lib/nginx/scgi \
--http-uwsgi-temp-path=/var/lib/nginx/uwsgi \
- --add-module=$srcdir/nginx-rtmp-module-$_rtmpver \
+ --with-cc-opt="$CFLAGS $CPPFLAGS" \
+ --with-ld-opt="$LDFLAGS" \
${_common_flags[@]} \
${_stable_flags[@]}
make
}
-package() {
+check() {
+ cd nginx-tests
+ TEST_NGINX_BINARY="$srcdir/$_pkgbase-$pkgver/objs/nginx" prove .
+}
+
+package_nginx-rtmp() {
cd $_pkgname-$pkgver
make DESTDIR="$pkgdir" install
@@ -125,3 +146,10 @@ package() {
"$pkgdir/usr/share/vim/vimfiles/$i/nginx.vim"
done
}
+
+package_nginx-rtmp-src() {
+ pkgdesc="Source code of nginx $pkgver, useful for building modules"
+ depends=()
+ install -d "$pkgdir/usr/src"
+ cp -r $_pkgbase-$pkgver-src "$pkgdir/usr/src/nginx"
+}
diff --git a/service b/service
index 365bc9568e0c..6302474f3674 100644
--- a/service
+++ b/service
@@ -10,7 +10,6 @@ SyslogLevel=err
ExecStart=/usr/bin/nginx -g 'pid /run/nginx.pid; error_log stderr;'
ExecReload=/usr/bin/nginx -s reload
-KillSignal=SIGQUIT
KillMode=mixed
[Install]