summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorpan934122019-04-13 15:21:56 +0800
committerpan934122019-04-13 15:21:56 +0800
commit60a04d1bb64aee9a9ce0f6c8efcae7b1ef9b37bc (patch)
tree8e65dbc67284b96662bfe4b8c177ee54dd0cc376
parent4d4e46a7a9b120aa5a7013dcd849bf0c7c798d28 (diff)
downloadaur-60a04d1bb64aee9a9ce0f6c8efcae7b1ef9b37bc.tar.gz
First commit of nginx--rtmp-sergey-git
-rw-r--r--PKGBUILD145
-rw-r--r--logrotate10
-rw-r--r--nginx.install27
-rw-r--r--service17
4 files changed, 177 insertions, 22 deletions
diff --git a/PKGBUILD b/PKGBUILD
index a6bbc4ba865b..4e80c8573649 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,28 +1,129 @@
-# Maintainer: Murat Çileli <murat.cileli@gmail.com>
-
-pkgbase="pkgbase"
-pkgname="adwaita-creamy"
-pkgver="0.1"
-pkgrel="1"
-pkgdesc="Refreshed new Adwaita theme with creamy colors and minor changes. "
-arch=("x86_64")
-license=("MIT")
-url="https://github.com/murat-cileli/adwaita-creamy"
-makedepends=()
-provides=("adwaita-creamy")
-
-source=("git+https://github.com/murat-cileli/adwaita-creamy.git")
-sha256sums=("SKIP")
+# PKGBUILD Author: Hui Yiqun <huiyiqun@gmail.com>
+# Maintainer: pan93412 <pan93412@gmail.com>
+
+_pkgname=nginx
+pkgname=$_pkgname-rtmp-sergey-git
+_nginx_ver=1.15.8
+_rtmp_commit_id=a5ac72c274
+pkgver=$_nginx_ver"_"$_rtmp_commit_id
+pkgrel=0
+pkgdesc='NGINX-based Media Streaming Server, forked by Sergey Dryabzhinsky.'
+arch=(x86_64)
+url='https://github.com/sergey-dryabzhinsky/nginx-rtmp-module'
+license=(custom)
+depends=(pcre zlib openssl geoip mailcap)
+backup=(etc/nginx/fastcgi.conf
+ etc/nginx/fastcgi_params
+ etc/nginx/koi-win
+ etc/nginx/koi-utf
+ etc/nginx/nginx.conf
+ etc/nginx/scgi_params
+ etc/nginx/uwsgi_params
+ etc/nginx/win-utf
+ etc/logrotate.d/nginx)
+install=nginx.install
+source=(https://nginx.org/download/nginx-$_nginx_ver.tar.gz
+ "nginx-rtmp-module-$_rtmp_commit_id::https://github.com/sergey-dryabzhinsky/nginx-rtmp-module#commit=$_rtmp_commit_id"
+ service
+ logrotate)
+provides=('nginx')
+conflicts=('nginx')
+md5sums=('49eecc51a45bdcc8cc147f6747ef8a4c'
+ SKIP
+ 'ef491e760e7c1ffec9ca25441a150c83'
+ '6a01fb17af86f03707c8ae60f98a2dc2')
+
+_common_flags=(
+ --with-compat
+ --with-file-aio
+ --with-http_addition_module
+ --with-http_auth_request_module
+ --with-http_dav_module
+ --with-http_degradation_module
+ --with-http_flv_module
+ --with-http_geoip_module
+ --with-http_gunzip_module
+ --with-http_gzip_static_module
+ --with-http_mp4_module
+ --with-http_realip_module
+ --with-http_secure_link_module
+ --with-http_slice_module
+ --with-http_ssl_module
+ --with-http_stub_status_module
+ --with-http_sub_module
+ --with-http_v2_module
+ --with-mail
+ --with-mail_ssl_module
+ --with-pcre-jit
+ --with-stream
+ --with-stream_geoip_module
+ --with-stream_realip_module
+ --with-stream_ssl_module
+ --with-stream_ssl_preread_module
+ --with-threads
+)
+
+_stable_flags=(
+)
build() {
- cd "${pkgname}"
- mkdir -p ~/.themes/adwaita-creamy
- cp gtk-2.0 ~/.themes/adwaita-creamy/ -R
- cp gtk-3.0 ~/.themes/adwaita-creamy/ -R
- cp index.theme ~/.themes/adwaita-creamy/
+ cd $_pkgname-$_nginx_ver
+
+ ./configure \
+ --prefix=/etc/nginx \
+ --conf-path=/etc/nginx/nginx.conf \
+ --sbin-path=/usr/bin/nginx \
+ --pid-path=/run/nginx.pid \
+ --lock-path=/run/lock/nginx.lock \
+ --user=http \
+ --group=http \
+ --http-log-path=/var/log/nginx/access.log \
+ --error-log-path=stderr \
+ --http-client-body-temp-path=/var/lib/nginx/client-body \
+ --http-proxy-temp-path=/var/lib/nginx/proxy \
+ --http-fastcgi-temp-path=/var/lib/nginx/fastcgi \
+ --http-scgi-temp-path=/var/lib/nginx/scgi \
+ --http-uwsgi-temp-path=/var/lib/nginx/uwsgi \
+ --add-module=$srcdir/nginx-rtmp-module-$_rtmp_commit_id \
+ ${_common_flags[@]} \
+ ${_stable_flags[@]}
+
+ make
}
package() {
- echo "Package"
-}
+ cd $_pkgname-$_nginx_ver
+ make DESTDIR="$pkgdir" install
+
+ sed -e 's|\<user\s\+\w\+;|user html;|g' \
+ -e '44s|html|/usr/share/nginx/html|' \
+ -e '54s|html|/usr/share/nginx/html|' \
+ -i "$pkgdir"/etc/nginx/nginx.conf
+
+ rm "$pkgdir"/etc/nginx/*.default
+ rm "$pkgdir"/etc/nginx/mime.types # in mailcap
+ install -d "$pkgdir"/var/lib/nginx
+ install -dm700 "$pkgdir"/var/lib/nginx/proxy
+
+ chmod 755 "$pkgdir"/var/log/nginx
+ chown root:root "$pkgdir"/var/log/nginx
+
+ install -d "$pkgdir"/usr/share/nginx
+ mv "$pkgdir"/etc/nginx/html/ "$pkgdir"/usr/share/nginx
+
+ install -Dm644 ../logrotate "$pkgdir"/etc/logrotate.d/nginx
+ install -Dm644 ../service "$pkgdir"/usr/lib/systemd/system/nginx.service
+ install -Dm644 LICENSE "$pkgdir"/usr/share/licenses/$_pkgname/LICENSE
+ install -Dm644 ../nginx-rtmp-module-$_rtmp_commit_id/LICENSE "$pkgdir"/usr/share/licenses/nginx-rtmp-module/LICENSE
+
+ rmdir "$pkgdir"/run
+
+ install -d "$pkgdir"/usr/share/man/man8/
+ gzip -9c man/nginx.8 > "$pkgdir"/usr/share/man/man8/nginx.8.gz
+
+ for i in ftdetect indent syntax; do
+ install -Dm644 contrib/vim/$i/nginx.vim \
+ "$pkgdir/usr/share/vim/vimfiles/$i/nginx.vim"
+ done
+}
diff --git a/logrotate b/logrotate
new file mode 100644
index 000000000000..e0afbb927021
--- /dev/null
+++ b/logrotate
@@ -0,0 +1,10 @@
+/var/log/nginx/*log {
+ missingok
+ notifempty
+ create 640 http log
+ sharedscripts
+ compress
+ postrotate
+ test ! -r /run/nginx.pid || kill -USR1 `cat /run/nginx.pid`
+ endscript
+}
diff --git a/nginx.install b/nginx.install
new file mode 100644
index 000000000000..d80514afe352
--- /dev/null
+++ b/nginx.install
@@ -0,0 +1,27 @@
+post_upgrade() {
+ if (( $(vercmp $2 1.2.7-4) <= 0 )); then
+ chmod 750 var/log/nginx
+ chown http:log var/log/nginx
+ fi
+
+ if (( $(vercmp $2 1.2.1-2) <= 0 )); then
+ echo ':: Since 1.2.1-2 several changes has been made in package:'
+ echo ' - *.conf files have been moved to /etc/nginx'
+ echo ' - /etc/conf.d/nginx has been removed'
+ echo ' Main configuration file is set to /etc/nginx/nginx.conf'
+ echo ' - access.log and error.log can be found in /var/log/nginx by default'
+ echo ' - bundled *.html files have been moved to /usr/share/nginx/html'
+ echo ' - /etc/nginx/{html,logs} symbolic links and *.default files have been removed'
+ fi
+
+ if (( $(vercmp $2 1.10.2-3) < 0)); then
+ chown root:root var/log/nginx
+ fi
+
+ if (( $(vercmp $2 1.10.3-2) < 0 )); then
+ chmod 755 var/log/nginx
+ echo ':: Security notice:'
+ echo ' - When additional log directories are used in /var/log/nginx make sure they'
+ echo ' are owned by root:root and have 755 set as permission to mitigate CVE-2016-1247'
+ fi
+}
diff --git a/service b/service
new file mode 100644
index 000000000000..365bc9568e0c
--- /dev/null
+++ b/service
@@ -0,0 +1,17 @@
+[Unit]
+Description=A high performance web server and a reverse proxy server
+After=network.target network-online.target nss-lookup.target
+
+[Service]
+Type=forking
+PIDFile=/run/nginx.pid
+PrivateDevices=yes
+SyslogLevel=err
+
+ExecStart=/usr/bin/nginx -g 'pid /run/nginx.pid; error_log stderr;'
+ExecReload=/usr/bin/nginx -s reload
+KillSignal=SIGQUIT
+KillMode=mixed
+
+[Install]
+WantedBy=multi-user.target