summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRoman Voropaev2018-01-01 18:23:02 +0300
committerRoman Voropaev2018-01-01 18:23:02 +0300
commit0a2a4efeab44358bbe149c38b62be2040e40a433 (patch)
tree498859b924f1691ee39b1e4a1b9fdafb91eef20b
parentb834742b9d07098715f2782b0180a45db1e4a109 (diff)
downloadaur-0a2a4efeab44358bbe149c38b62be2040e40a433.tar.gz
Fixes from https://bbs.archlinux.org/viewtopic.php\?id\=164312
-rw-r--r--PKGBUILD35
1 files changed, 20 insertions, 15 deletions
diff --git a/PKGBUILD b/PKGBUILD
index c729f8cddf29..54653b5aa913 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,34 +1,39 @@
# Contributor: Roman Voropaev <voropaev.roma@gmail.com>
-pkgbase=nginx-unit
+pkgbase='nginx-unit'
pkgname=('nginx-unit-python' 'nginx-unit-php')
-_shortname=unit
+_shortname='unit'
pkgver=0.3
pkgrel=1
pkgdesc="Dynamic web application server, designed to run applications in multiple languages."
arch=('i686' 'x86_64')
url="http://unit.nginx.org/"
license=('Apache-2.0')
-optdepends=('python' 'php-embed')
-source=(http://hg.nginx.org/$_shortname/archive/$pkgver.tar.gz)
-md5sums=(62ac119c9e345e0b447356b543111b33)
+source=($pkgbase-$pkgver.tar.gz::"https://hg.nginx.org/$_shortname/archive/$pkgver.tar.gz")
+md5sums=("62ac119c9e345e0b447356b543111b33")
+makedepends=('php-embed' 'python')
build() {
- cd $srcdir/$_shortname-$pkgver
+ cd "$srcdir"/$_shortname-$pkgver
./configure --prefix=/usr
- make || return 1
+ ./configure python
+ ./configure php
+ make all
+}
+
+package_nginx-unit() {
+ cd "$srcdir"/$_shortname-$pkgver
+ make DESTDIR="$pkgdir" unitd-install
}
package_nginx-unit-python() {
- cd $srcdir/$_shortname-$pkgver
- ./configure python
- make python
- make DESTDIR=$pkgdir install || return 1
+ depends=('nginx-unit' 'python')
+ cd "$srcdir"/$_shortname-$pkgver
+ make DESTDIR="$pkgdir" python-install
}
package_nginx-unit-php() {
- cd $srcdir/$_shortname-$pkgver
- ./configure php
- make php
- make DESTDIR=$pkgdir install || return 1
+ depends=('nginx-unit' 'php')
+ cd "$srcdir"/$_shortname-$pkgver
+ make DESTDIR="$pkgdir" php-install
}