summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRoman Voropaev2018-01-01 18:44:19 +0300
committerRoman Voropaev2018-01-01 18:44:19 +0300
commit9ffc950aa437f73cba86ea2972b4c61bc85f8262 (patch)
tree8b80c3a52811384025d9ef1836a2a365ed29b569
parent49aadae5b1e7f46260c52c73696743d13437f6e9 (diff)
downloadaur-9ffc950aa437f73cba86ea2972b4c61bc85f8262.tar.gz
Final fix in package names
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD10
2 files changed, 8 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 70b1afbb4f8c..c0a29f8b59c8 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -11,13 +11,13 @@ pkgbase = nginx-unit
source = nginx-unit-0.3.tar.gz::https://hg.nginx.org/unit/archive/0.3.tar.gz
md5sums = 62ac119c9e345e0b447356b543111b33
-pkgname = nginx-unit
+pkgname = nginx-unitd
pkgname = nginx-unit-python
- depends = nginx-unit
+ depends = nginx-unitd
depends = python
pkgname = nginx-unit-php
- depends = nginx-unit
+ depends = nginx-unitd
depends = php
diff --git a/PKGBUILD b/PKGBUILD
index 4a229ba6dc64..cb3fef5b13db 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Contributor: Roman Voropaev <voropaev.roma@gmail.com>
pkgbase='nginx-unit'
-pkgname=('nginx-unit' 'nginx-unit-python' 'nginx-unit-php')
+pkgname=('nginx-unitd' 'nginx-unit-python' 'nginx-unit-php')
_shortname='unit'
pkgver=0.3
pkgrel=3
@@ -15,25 +15,25 @@ makedepends=('php-embed' 'python')
build() {
cd "$srcdir"/$_shortname-$pkgver
- ./configure --prefix=/usr
+ ./configure --prefix=/usr --sbindir=/usr/bin
./configure python
./configure php
make all
}
-package_nginx-unit() {
+package_nginx-unitd() {
cd "$srcdir"/$_shortname-$pkgver
make DESTDIR="$pkgdir" unitd-install
}
package_nginx-unit-python() {
- depends=('nginx-unit' 'python')
+ depends=('nginx-unitd' 'python')
cd "$srcdir"/$_shortname-$pkgver
make DESTDIR="$pkgdir" python-install
}
package_nginx-unit-php() {
- depends=('nginx-unit' 'php')
+ depends=('nginx-unitd' 'php')
cd "$srcdir"/$_shortname-$pkgver
make DESTDIR="$pkgdir" php-install
}