summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRoman Voropaev2018-01-28 22:05:16 +0300
committerRoman Voropaev2018-01-28 22:05:16 +0300
commitb5a4f3f519ee580a0bc7ddee53aae58ea725333d (patch)
tree5a568fb316f779a9a922b1a212dc61fa98a96638
parent10ccc4ce9ad14272e4541faa111e7958c8479b0a (diff)
downloadaur-b5a4f3f519ee580a0bc7ddee53aae58ea725333d.tar.gz
Go support
-rw-r--r--.SRCINFO11
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD13
3 files changed, 19 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 39e5beb36226..0b0b8b36b772 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,16 @@
pkgbase = nginx-unit
pkgdesc = Dynamic web application server, designed to run applications in multiple languages.
pkgver = 0.4
- pkgrel = 1
+ pkgrel = 2
url = http://unit.nginx.org/
arch = i686
arch = x86_64
license = Apache-2.0
makedepends = php-embed
makedepends = python
- source = nginx-unit-0.3.tar.gz::https://hg.nginx.org/unit/archive/0.3.tar.gz
- md5sums = 62ac119c9e345e0b447356b543111b33
+ makedepends = go
+ source = nginx-unit-0.4.tar.gz::https://hg.nginx.org/unit/archive/0.4.tar.gz
+ md5sums = 11555971d26ea16723516485670543ee
pkgname = nginx-unitd
@@ -21,3 +22,7 @@ pkgname = nginx-unit-php
depends = nginx-unitd
depends = php
+pkgname = nginx-unit-go
+ depends = nginx-unitd
+ depends = go
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..9881fec21af4
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1 @@
+*.tar.*
diff --git a/PKGBUILD b/PKGBUILD
index 56c17506868d..91108515ca69 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,23 +1,24 @@
# Contributor: Roman Voropaev <voropaev.roma@gmail.com>
pkgbase='nginx-unit'
-pkgname=('nginx-unitd' 'nginx-unit-python' 'nginx-unit-php')
+pkgname=('nginx-unitd' 'nginx-unit-python' 'nginx-unit-php' 'nginx-unit-go')
_shortname='unit'
pkgver=0.4
-pkgrel=1
+pkgrel=2
pkgdesc="Dynamic web application server, designed to run applications in multiple languages."
arch=('i686' 'x86_64')
url="http://unit.nginx.org/"
license=('Apache-2.0')
source=($pkgbase-$pkgver.tar.gz::"https://hg.nginx.org/$_shortname/archive/$pkgver.tar.gz")
md5sums=("11555971d26ea16723516485670543ee")
-makedepends=('php-embed' 'python')
+makedepends=('php-embed' 'python' 'go')
build() {
cd "$srcdir"/$_shortname-$pkgver
./configure --prefix=/usr --sbindir=/usr/bin
./configure python
./configure php
+ ./configure go
make all
}
@@ -38,3 +39,9 @@ package_nginx-unit-php() {
cd "$srcdir"/$_shortname-$pkgver
make DESTDIR="$pkgdir" php-install
}
+
+package_nginx-unit-go() {
+ depends=('nginx-unitd' 'go')
+ cd "$srcdir"/$_shortname-$pkgver
+ make DESTDIR="$pkgdir" go-install
+}