summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKawaiDesu2020-11-08 00:07:53 +0300
committerKawaiDesu2020-11-08 00:07:53 +0300
commitf99b0d7d56b1ae11d8db2313c3a5e06aaea5210c (patch)
treec46669f6a746b19ab4ce6654467a1bb8ec4a62b5
parent5cedce1b63377f7892c77447cfdf57601ad9fbf4 (diff)
downloadaur-f99b0d7d56b1ae11d8db2313c3a5e06aaea5210c.tar.gz
Bump to 1.20.0 and add libunit
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD15
2 files changed, 17 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 569ffa718e26..6c4f3c6548d2 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = nginx-unit
pkgdesc = Lightweight, dynamic, open-source server for diverse web applications.
- pkgver = 1.19.0
- pkgrel = 2
+ pkgver = 1.20.0
+ pkgrel = 1
url = https://unit.nginx.org/
arch = i686
arch = x86_64
@@ -13,15 +13,17 @@ pkgbase = nginx-unit
makedepends = ruby
makedepends = perl
makedepends = npm
- source = https://unit.nginx.org/download/unit-1.19.0.tar.gz
+ source = https://unit.nginx.org/download/unit-1.20.0.tar.gz
source = unit.service
- sha256sums = 8cb849420221932685689708235efbfef2024656f856b72887ae9ff1cf75f98b
+ sha256sums = ee39a801f83aff5dfff94336f688fd9cfbd02fee270edd8711b10be4fe298d32
sha256sums = 8c9b2f732d6e50aa747aa7703303e5fff69f5abc6f5fc1741b774b422e029606
pkgname = nginx-unitd
depends = glibc
depends = openssl
+pkgname = nginx-libunit
+
pkgname = nginx-unit-python
depends = nginx-unitd
depends = python
diff --git a/PKGBUILD b/PKGBUILD
index 9992ace086a2..e3a27bb641d1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,10 +1,12 @@
# Maintainer: KawaiDesu <zmey1992@ya.ru>
# Contributor: @whoami
# Contributor: Roman Voropaev <voropaev.roma@gmail.com>
-# Contributor:: Julian Brost <julian@0x4a42.net>
+# Contributor: Julian Brost <julian@0x4a42.net>
+# Contributor: Lorenzo Gabriele <lorenzolespaul@gmail.com>
pkgbase='nginx-unit'
pkgname=('nginx-unitd'
+ 'nginx-libunit'
'nginx-unit-python'
'nginx-unit-python2'
'nginx-unit-php'
@@ -13,15 +15,15 @@ pkgname=('nginx-unitd'
'nginx-unit-nodejs'
'nginx-unit-go')
_shortname='unit'
-pkgver=1.19.0
-pkgrel=2
+pkgver=1.20.0
+pkgrel=1
pkgdesc="Lightweight, dynamic, open-source server for diverse web applications."
arch=('i686' 'x86_64')
url="https://unit.nginx.org/"
license=('Apache')
source=("https://unit.nginx.org/download/unit-$pkgver.tar.gz"
'unit.service')
-sha256sums=('8cb849420221932685689708235efbfef2024656f856b72887ae9ff1cf75f98b'
+sha256sums=('ee39a801f83aff5dfff94336f688fd9cfbd02fee270edd8711b10be4fe298d32'
'8c9b2f732d6e50aa747aa7703303e5fff69f5abc6f5fc1741b774b422e029606')
makedepends=('php-embed' 'python' 'python2' 'go' 'ruby' 'perl' 'npm')
@@ -54,6 +56,11 @@ package_nginx-unitd() {
install -m 644 -D "${srcdir}/unit.service" "${pkgdir}/usr/lib/systemd/system/unit.service"
}
+package_nginx-libunit() {
+ cd "${srcdir}/${_shortname}-${pkgver}"
+ make DESTDIR="${pkgdir}" libunit-install
+}
+
package_nginx-unit-python() {
depends=('nginx-unitd' 'python')