summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMariusz Chilmon2020-02-07 22:53:10 +0100
committerMariusz Chilmon2020-02-07 22:53:10 +0100
commit456d564863799b7a475229be10e1d73c246018f1 (patch)
tree868a3271fc2bb858445c5efcddd0459fd087323e
downloadaur-456d564863799b7a475229be10e1d73c246018f1.tar.gz
Initial commit.
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD37
2 files changed, 55 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..05fa5081fcd4
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = nginx-upload-module
+ pkgdesc = Module for nginx web server for handling file uploads using multipart/form-data encoding (RFC 1867)
+ pkgver = 2.3.0
+ pkgrel = 1
+ url = https://github.com/vkholodkov/nginx-upload-module
+ arch = x86_64
+ license = BSD
+ depends = nginx=1.16.1
+ source = https://nginx.org/download/nginx-1.16.1.tar.gz
+ source = https://nginx.org/download/nginx-1.16.1.tar.gz.asc
+ source = nginx-upload-module-2.3.0.tar.gz::https://github.com/vkholodkov/nginx-upload-module/archive/2.3.0.tar.gz
+ validpgpkeys = B0F4253373F8F6F510D42178520A9993A1C052F8
+ sha256sums = f11c2a6dd1d3515736f0324857957db2de98be862461b5a542a3ac6188dbe32b
+ sha256sums = SKIP
+ sha256sums = c86e318addb9c88d70fdbd58ff1f6ef6f404a93070f6db8017a1f880c97946c4
+
+pkgname = nginx-upload-module
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..356117e1d26f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# Maintainer: Mariusz Chilmon <vmario1986 plus aur at gmail dot com>
+
+pkgname=nginx-upload-module
+pkgver=2.3.0
+pkgrel=1
+pkgdesc="Module for nginx web server for handling file uploads using multipart/form-data encoding (RFC 1867)"
+arch=('x86_64')
+
+_dirname="nginx-upload-module-$pkgver"
+_nginxver=1.16.1
+
+url='https://github.com/vkholodkov/nginx-upload-module'
+license=('BSD')
+depends=("nginx=$_nginxver")
+
+source=(
+ https://nginx.org/download/nginx-$_nginxver.tar.gz{,.asc}
+ "$pkgname-$pkgver.tar.gz::https://github.com/vkholodkov/nginx-upload-module/archive/${pkgver}.tar.gz"
+)
+validpgpkeys=(B0F4253373F8F6F510D42178520A9993A1C052F8) # Maxim Dounin <mdounin@mdounin.ru>
+sha256sums=('f11c2a6dd1d3515736f0324857957db2de98be862461b5a542a3ac6188dbe32b'
+ 'SKIP'
+ 'c86e318addb9c88d70fdbd58ff1f6ef6f404a93070f6db8017a1f880c97946c4')
+
+build() {
+ cd "$srcdir"/nginx-$_nginxver
+ ./configure --with-compat --add-dynamic-module="../$_dirname"
+ make modules
+}
+
+package() {
+ install -Dm755 "$srcdir/$_dirname/LICENCE" "$pkgdir/usr/share/licenses/${pkgname}/LICENSE"
+ cd "$srcdir"/nginx-$_nginxver/objs
+ for mod in ngx_*.so; do
+ install -Dm755 $mod "$pkgdir"/usr/lib/nginx/modules/$mod
+ done
+}