summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDiab Neiroukh2020-04-24 17:15:14 +0100
committerDiab Neiroukh2020-04-24 17:15:14 +0100
commit0f8312b3acd1ca9966a27d8f62c552d278aef7b4 (patch)
treef8547a75445952e5815821c1a9d36f0acaa0beae
parenta01571295fbf06f97781324ca9dff8dc9764da22 (diff)
downloadaur-0f8312b3acd1ca9966a27d8f62c552d278aef7b4.tar.gz
🐛 FIX: Use more leniant compiler flags to avoid failing the build
-rw-r--r--.SRCINFO1
-rw-r--r--PKGBUILD5
2 files changed, 4 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b7444adf2ae3..4eac52b60178 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,7 @@
pkgbase = nginx-zest-git
pkgver = 1.17.10
pkgrel = 1
+ epoch = 1
url = https://github.com/ZestProjects/nginx
arch = x86_64
license = custom
diff --git a/PKGBUILD b/PKGBUILD
index e82b326c702e..516fd9f20399 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,6 +7,7 @@ pkgname=(
)
pkgver=1.17.10
pkgrel=1
+epoch=1
arch=(
"x86_64"
)
@@ -109,8 +110,8 @@ prepare()
build()
{
#* We need to manually state the compielr flags as quiche is sensitive to changes here
- export CFLAGS="-march=x86_64 -mtune=generic -O3 -pipe -fno-plt"
- export CXXFLAGS="${CFLAGS}"
+ export CFLAGS="-O3 -pipe -fno-plt"
+ export CXXFLAGS="-O3 -pipe -fno-plt"
cd "nginx" || exit
./auto/configure \