summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDiab Neiroukh2020-05-02 17:04:34 +0100
committerDiab Neiroukh2020-05-02 17:04:34 +0100
commit1bc37f50c27c064edad3a053ea1ad941da877a60 (patch)
treef44713c7ab516a6892ac1f074c5d6e03b0a8b298
parent354fdd30bb669db78399cdda22a7226bd24f035a (diff)
downloadaur-1bc37f50c27c064edad3a053ea1ad941da877a60.tar.gz
👌 IMPROVE: Use TCMalloc for improved memory allocations
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD7
2 files changed, 5 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1d3e995e1b9e..bb645e839cb1 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = nginx-zest-git
pkgver = 1.17.10
- pkgrel = 1
+ pkgrel = 2
epoch = 3
url = https://github.com/ZestProjects/nginx
arch = x86_64
diff --git a/PKGBUILD b/PKGBUILD
index 9544f8c70fd8..f1453673a6df 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,7 +6,7 @@ pkgname=(
"nginx-zest-src-git"
)
pkgver=1.17.10
-pkgrel=1
+pkgrel=2
epoch=3
arch=(
"x86_64"
@@ -144,8 +144,9 @@ prepare()
build()
{
#* Manually state the compiler flags
- export CFLAGS="-march=x86-64 -mtune=generic -O3 -pipe -fno-plt"
- export CXXFLAGS="-march=x86-64 -mtune=generic -O3 -pipe -fno-plt"
+ export CFLAGS="-march=x86-64 -mtune=generic -O3 -pipe -fno-plt -fno-builtin-malloc -fno-builtin-calloc -fno-builtin-realloc -fno-builtin-free"
+ export CXXFLAGS="-march=x86-64 -mtune=generic -O3 -pipe -fno-plt -fno-builtin-malloc -fno-builtin-calloc -fno-builtin-realloc -fno-builtin-free"
+ export LDFLAGS="$LDFLAGS -ltcmalloc"
cd "nginx" || exit
./auto/configure \